summaryrefslogtreecommitdiff
path: root/wire-gateway/Cargo.toml
diff options
context:
space:
mode:
authorAntoine A <>2021-12-09 16:52:55 +0100
committerAntoine A <>2021-12-09 16:52:55 +0100
commitf9fe9248934080e57b5359dab4b53d0b1852f9b5 (patch)
treefebc6003668317b31425d3d90b8a5cce0d8995c5 /wire-gateway/Cargo.toml
parentb4876e58b2d95e3745978717ed6efa763b054d08 (diff)
downloaddepolymerization-f9fe9248934080e57b5359dab4b53d0b1852f9b5.tar.gz
depolymerization-f9fe9248934080e57b5359dab4b53d0b1852f9b5.tar.bz2
depolymerization-f9fe9248934080e57b5359dab4b53d0b1852f9b5.zip
Improve resilience against malicious request
Diffstat (limited to 'wire-gateway/Cargo.toml')
-rw-r--r--wire-gateway/Cargo.toml16
1 files changed, 5 insertions, 11 deletions
diff --git a/wire-gateway/Cargo.toml b/wire-gateway/Cargo.toml
index bb71613..8839323 100644
--- a/wire-gateway/Cargo.toml
+++ b/wire-gateway/Cargo.toml
@@ -11,13 +11,7 @@ test = []
# Http library
hyper = { version = "0.14.15", features = ["http1", "server", "runtime"] }
# Async runtime
-tokio = { version = "1.14.0", features = [
- "net",
- "macros",
- "rt-multi-thread",
- "io-std",
- "io-util",
-] }
+tokio = { version = "1.14.0", features = ["net", "macros", "rt-multi-thread"] }
# Serialization framework
serde = { version = "1.0.130", features = ["derive"] }
# Serialization helper
@@ -30,8 +24,8 @@ serde_urlencoded = "0.7.0"
base32 = "0.4.0"
# Error macros
thiserror = "1.0.30"
-# Async friendly compression
-async-compression = { version = "0.3.8", features = ["tokio", "zlib"] }
+# Deflate compression
+miniz_oxide = "0.5.1"
# Rng
rand = { version = "0.8.4", features = ["getrandom"] }
# Url format
@@ -39,8 +33,8 @@ url = { version = "2.2.2", features = ["serde"] }
# Async postgres client
tokio-postgres = { version = "0.7.5" }
# Logging
-taler-log = {path = "../taler-log"}
+taler-log = { path = "../taler-log" }
# TODO Put this behind a feature
# Bitcoin data structure
-bitcoin = "0.27.1" \ No newline at end of file
+bitcoin = "0.27.1"