summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c486435..e3cab4a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,12 @@ pkgdata_DATA = \
all: taler-wallet-lib.js taler-wallet-jsless.js
-if HAVE_TSC
%.js: %.ts
+if HAVE_TSC
tsc $<
+else
+ @echo
+ @echo "*** Error: typescript compiler 'tsc' is missing, can't build" $@
+ @echo
+ @exit 1
endif