summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-03 11:37:26 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-03 11:37:26 +0200
commitd4568d219503248b02046ba9b377b31a8c9e8d58 (patch)
treee9c2c0c29da199d0b5376a935feb215034b18641 /Makefile.am
parent00655b756b46eb1004f2cfe2b4130fba5ad0aec1 (diff)
downloadweb-common-d4568d219503248b02046ba9b377b31a8c9e8d58.tar.gz
web-common-d4568d219503248b02046ba9b377b31a8c9e8d58.tar.bz2
web-common-d4568d219503248b02046ba9b377b31a8c9e8d58.zip
Makefile.am: print nice error message if typescript compiler is missing.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c486435..e3cab4a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,12 @@ pkgdata_DATA = \
all: taler-wallet-lib.js taler-wallet-jsless.js
-if HAVE_TSC
%.js: %.ts
+if HAVE_TSC
tsc $<
+else
+ @echo
+ @echo "*** Error: typescript compiler 'tsc' is missing, can't build" $@
+ @echo
+ @exit 1
endif