summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml57
1 files changed, 57 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..0b85b26
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,57 @@
+[tool.poetry]
+name = "talermerchantdemos"
+version = "0.8.1"
+description = "Taler merchant demos"
+authors = [
+ "Florian Dold <dold@taler.net>",
+ "Marcello Stanisci <ms@taler.net>",
+ "Christian Grothoff <grothoff@taler.net>",
+]
+license = "AGPL3+"
+include = [
+ # Common
+ "static/*.css",
+ "static/*.svg",
+ "templates/*.j2",
+ # Landing files
+ "landing/templates/*.j2",
+ "landing/static/*.css",
+ "landing/translations/*/LC_MESSAGES/*.mo",
+ # Blog files
+ "blog/templates/*.html",
+ "blog/templates/*.j2",
+ "blog/static/favicon.ico",
+ "blog/static/*.css",
+ #"blog/articles/*/*",
+ "blog/translations/*/LC_MESSAGES/*.mo",
+ "translations/*/LC_MESSAGES/*.mo",
+ "blog/data/*",
+ # Donation files
+ "donations/templates/*.j2",
+ "donations/static/*.css",
+ "donations/translations/*/LC_MESSAGES/*.mo",
+ # Survey files
+ "survey/templates/*.j2",
+ "survey/static/favicon.ico",
+ "survey/static/*.js",
+ "survey/static/*.css",
+ "survey/translations/*/LC_MESSAGES/*.mo",
+]
+
+
+[tool.poetry.dependencies]
+python = "^3.8"
+Flask = "^2.0.2"
+requests = "^2.26.0"
+taler-util = "^0.8.3"
+beautifulsoup4 = "^4.10.0"
+
+[tool.poetry.dev-dependencies]
+
+[tool.poetry.scripts]
+taler-merchant-demos = 'talermerchantdemos.cli:run'
+
+
+[build-system]
+requires = ["poetry-core>=1.0.0"]
+build-backend = "poetry.core.masonry.api"