diff options
Diffstat (limited to 'src/backend/melted/Makefile.am')
-rw-r--r-- | src/backend/melted/Makefile.am | 61 |
1 files changed, 61 insertions, 0 deletions
diff --git a/src/backend/melted/Makefile.am b/src/backend/melted/Makefile.am new file mode 100644 index 00000000..14b36e8a --- /dev/null +++ b/src/backend/melted/Makefile.am | |||
@@ -0,0 +1,61 @@ | |||
1 | # This Makefile.am is in the public domain | ||
2 | AM_CPPFLAGS = -I$(top_srcdir)/src/include | ||
3 | |||
4 | if USE_COVERAGE | ||
5 | AM_CFLAGS = --coverage -O0 | ||
6 | XLIB = -lgcov | ||
7 | endif | ||
8 | |||
9 | bin_PROGRAMS = \ | ||
10 | taler-mint-httpd \ | ||
11 | taler-merchant-httpd | ||
12 | |||
13 | taler_mint_httpd_SOURCES = \ | ||
14 | taler-mint-httpd.c taler-mint-httpd.h \ | ||
15 | taler-mint-httpd_keystate.c taler-mint-httpd_keystate.h \ | ||
16 | taler-mint-httpd_db.c taler-mint-httpd_db.h \ | ||
17 | taler-mint-httpd_parsing.c taler-mint-httpd_parsing.h \ | ||
18 | taler-mint-httpd_responses.c taler-mint-httpd_responses.h \ | ||
19 | taler-mint-httpd_mhd.c taler-mint-httpd_mhd.h \ | ||
20 | taler-mint-httpd_admin.c taler-mint-httpd_admin.h \ | ||
21 | taler-mint-httpd_deposit.c taler-mint-httpd_deposit.h \ | ||
22 | taler-mint-httpd_withdraw.c taler-mint-httpd_withdraw.h \ | ||
23 | taler-mint-httpd_refresh.c taler-mint-httpd_refresh.h | ||
24 | taler_mint_httpd_LDADD = \ | ||
25 | $(LIBGCRYPT_LIBS) \ | ||
26 | $(top_builddir)/src/util/libtalerutil.la \ | ||
27 | $(top_builddir)/src/mintdb/libtalermintdb.la \ | ||
28 | -lmicrohttpd \ | ||
29 | -ljansson \ | ||
30 | -lgnunetutil \ | ||
31 | -lpthread | ||
32 | taler_merchant_httpd_SOURCES = \ | ||
33 | taler-merchant-httpd.c \ | ||
34 | merchant.c merchant.h \ | ||
35 | merchant_db.c merchant_db.h \ | ||
36 | taler-mint-httpd_keystate.c taler-mint-httpd_keystate.h \ | ||
37 | taler-mint-httpd_db.c taler-mint-httpd_db.h \ | ||
38 | taler-mint-httpd_parsing.c taler-mint-httpd_parsing.h \ | ||
39 | taler-mint-httpd_responses.c taler-mint-httpd_responses.h \ | ||
40 | taler-mint-httpd_mhd.c taler-mint-httpd_mhd.h \ | ||
41 | taler-mint-httpd_admin.c taler-mint-httpd_admin.h \ | ||
42 | taler-mint-httpd_deposit.c taler-mint-httpd_deposit.h \ | ||
43 | taler-mint-httpd_withdraw.c taler-mint-httpd_withdraw.h \ | ||
44 | taler-mint-httpd_refresh.c taler-mint-httpd_refresh.h | ||
45 | |||
46 | taler_merchant_httpd_LDADD = \ | ||
47 | $(LIBGCRYPT_LIBS) \ | ||
48 | $(top_builddir)/src/util/libtalerutil.la \ | ||
49 | $(top_builddir)/src/mintdb/libtalermintdb.la \ | ||
50 | -lmicrohttpd \ | ||
51 | -ljansson \ | ||
52 | -lgnunetutil \ | ||
53 | -ltalerpq \ | ||
54 | -lgnunetpostgres \ | ||
55 | -lpq \ | ||
56 | -lpthread | ||
57 | |||
58 | if HAVE_DEVELOPER | ||
59 | taler_mint_httpd_SOURCES += \ | ||
60 | taler-mint-httpd_test.c taler-mint-httpd_test.h | ||
61 | endif | ||