summaryrefslogtreecommitdiff
path: root/src/backend/melted/Makefile.am
diff options
context:
space:
mode:
authorMarcello Stanisci <marcello.stanisci@inria.fr>2015-08-03 18:22:37 +0200
committerMarcello Stanisci <marcello.stanisci@inria.fr>2015-08-03 18:22:37 +0200
commit3b654e614be19326dedaad791723234fa145e3c9 (patch)
tree1ee09b2f612862406568ce21b7578311b434992d /src/backend/melted/Makefile.am
parent4e8112a444a4b93efe8f439a40d1f78faea49d2f (diff)
downloadmerchant-3b654e614be19326dedaad791723234fa145e3c9.tar.gz
merchant-3b654e614be19326dedaad791723234fa145e3c9.tar.bz2
merchant-3b654e614be19326dedaad791723234fa145e3c9.zip
Adding the 'melted' directory. Its purpose is to keep the files that
implement the merchant http daemon. Those files are to be placed inside the mint/src/mint directory to be compiled; that happens since the merchant needs some routines for handling JSON data that are (still?) not exported by the mint as a shared library. In other words, the development of those files happens inside the mint's tree, but their backup happens here.
Diffstat (limited to 'src/backend/melted/Makefile.am')
-rw-r--r--src/backend/melted/Makefile.am61
1 files changed, 61 insertions, 0 deletions
diff --git a/src/backend/melted/Makefile.am b/src/backend/melted/Makefile.am
new file mode 100644
index 00000000..14b36e8a
--- /dev/null
+++ b/src/backend/melted/Makefile.am
@@ -0,0 +1,61 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+bin_PROGRAMS = \
+ taler-mint-httpd \
+ taler-merchant-httpd
+
+taler_mint_httpd_SOURCES = \
+ taler-mint-httpd.c taler-mint-httpd.h \
+ taler-mint-httpd_keystate.c taler-mint-httpd_keystate.h \
+ taler-mint-httpd_db.c taler-mint-httpd_db.h \
+ taler-mint-httpd_parsing.c taler-mint-httpd_parsing.h \
+ taler-mint-httpd_responses.c taler-mint-httpd_responses.h \
+ taler-mint-httpd_mhd.c taler-mint-httpd_mhd.h \
+ taler-mint-httpd_admin.c taler-mint-httpd_admin.h \
+ taler-mint-httpd_deposit.c taler-mint-httpd_deposit.h \
+ taler-mint-httpd_withdraw.c taler-mint-httpd_withdraw.h \
+ taler-mint-httpd_refresh.c taler-mint-httpd_refresh.h
+taler_mint_httpd_LDADD = \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/mintdb/libtalermintdb.la \
+ -lmicrohttpd \
+ -ljansson \
+ -lgnunetutil \
+ -lpthread
+taler_merchant_httpd_SOURCES = \
+ taler-merchant-httpd.c \
+ merchant.c merchant.h \
+ merchant_db.c merchant_db.h \
+ taler-mint-httpd_keystate.c taler-mint-httpd_keystate.h \
+ taler-mint-httpd_db.c taler-mint-httpd_db.h \
+ taler-mint-httpd_parsing.c taler-mint-httpd_parsing.h \
+ taler-mint-httpd_responses.c taler-mint-httpd_responses.h \
+ taler-mint-httpd_mhd.c taler-mint-httpd_mhd.h \
+ taler-mint-httpd_admin.c taler-mint-httpd_admin.h \
+ taler-mint-httpd_deposit.c taler-mint-httpd_deposit.h \
+ taler-mint-httpd_withdraw.c taler-mint-httpd_withdraw.h \
+ taler-mint-httpd_refresh.c taler-mint-httpd_refresh.h
+
+taler_merchant_httpd_LDADD = \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/mintdb/libtalermintdb.la \
+ -lmicrohttpd \
+ -ljansson \
+ -lgnunetutil \
+ -ltalerpq \
+ -lgnunetpostgres \
+ -lpq \
+ -lpthread
+
+if HAVE_DEVELOPER
+taler_mint_httpd_SOURCES += \
+ taler-mint-httpd_test.c taler-mint-httpd_test.h
+endif