summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-12-28 11:39:05 +0100
committerChristian Grothoff <christian@grothoff.org>2020-12-28 11:39:05 +0100
commit351b289675cc9a52a86f5daedd430942d680c410 (patch)
tree9b27178c1945d9717143a2e1ff08c9eecd898af0 /debian/rules
parente550acf5779f8b5da31bc97b35f77ff3f1935c0b (diff)
downloadexchange-351b289675cc9a52a86f5daedd430942d680c410.tar.gz
exchange-351b289675cc9a52a86f5daedd430942d680c410.tar.bz2
exchange-351b289675cc9a52a86f5daedd430942d680c410.zip
skeleton for Taler exchange Debian package (not yet working)
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules35
1 files changed, 35 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 000000000..75c683a8c
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,35 @@
+#!/usr/bin/make -f
+
+SHELL := sh -e
+
+include /usr/share/dpkg/architecture.mk
+
+%:
+ dh ${@}
+
+override_dh_auto_configure-arch:
+ dh_auto_configure -- --disable-rpath --with-microhttpd=yes $(shell dpkg-buildflags --export=configure)
+
+override_dh_auto_configure-indep:
+
+override_dh_auto_build-indep:
+
+override_dh_auto_test:
+ # Disabling test suite, incomplete
+
+override_dh_auto_install-arch:
+ dh_auto_install
+
+ # Create config file
+ mkdir -p debian/tmp/etc
+ cp debian/etc/taler.conf debian/tmp/etc/
+
+ # Removing useless files
+ rm -f debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/*.la \
+ debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/taler/*.la \
+ debian/tmp/usr/share/doc/taler/COPYING
+
+override_dh_auto_install-indep:
+
+override_dh_auto_clean:
+ dh_auto_clean