summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules35
1 files changed, 35 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 000000000..75c683a8c
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,35 @@
+#!/usr/bin/make -f
+
+SHELL := sh -e
+
+include /usr/share/dpkg/architecture.mk
+
+%:
+ dh ${@}
+
+override_dh_auto_configure-arch:
+ dh_auto_configure -- --disable-rpath --with-microhttpd=yes $(shell dpkg-buildflags --export=configure)
+
+override_dh_auto_configure-indep:
+
+override_dh_auto_build-indep:
+
+override_dh_auto_test:
+ # Disabling test suite, incomplete
+
+override_dh_auto_install-arch:
+ dh_auto_install
+
+ # Create config file
+ mkdir -p debian/tmp/etc
+ cp debian/etc/taler.conf debian/tmp/etc/
+
+ # Removing useless files
+ rm -f debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/*.la \
+ debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/taler/*.la \
+ debian/tmp/usr/share/doc/taler/COPYING
+
+override_dh_auto_install-indep:
+
+override_dh_auto_clean:
+ dh_auto_clean