summaryrefslogtreecommitdiff
path: root/wire-gateway/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'wire-gateway/Cargo.toml')
-rw-r--r--wire-gateway/Cargo.toml15
1 files changed, 8 insertions, 7 deletions
diff --git a/wire-gateway/Cargo.toml b/wire-gateway/Cargo.toml
index b5f500c..7d6a46e 100644
--- a/wire-gateway/Cargo.toml
+++ b/wire-gateway/Cargo.toml
@@ -11,22 +11,22 @@ hyper = { version = "0.14.23", features = ["http1", "server", "runtime"] }
# Hyper compat lib for unix domain socket
hyperlocal = "0.8.0"
# Async runtime
-tokio = { version = "1.23.0", features = ["net", "macros", "rt-multi-thread"] }
+tokio = { version = "1.24.2", features = ["net", "macros", "rt-multi-thread"] }
# Serialization framework
-serde = { version = "1.0.149", features = ["derive"] }
+serde = { version = "1.0.152", features = ["derive"] }
# Serialization helper
-serde_with = "2.1.0"
+serde_with = "2.2.0"
# JSON serialization
-serde_json = "1.0.89"
+serde_json = "1.0.91"
# Url query serialization
serde_urlencoded = "0.7.1"
# Error macros
-thiserror = "1.0.37"
+thiserror = "1.0.38"
# Deflate compression
miniz_oxide = "0.6.2"
# Async postgres client
tokio-postgres = { version = "0.7.7" }
-deadpool-postgres = "0.10.3"
+deadpool-postgres = "0.10.4"
# Socket activation
listenfd = "1.0.0"
# Common lib
@@ -36,7 +36,8 @@ bitcoin = { version = "0.29.2" }
# Ethereum types
ethereum-types = { version = "0.14.1", default-features = false }
# Cli args parser
-clap = { version = "4.0.29", features = ["derive"] }
+clap = { version = "=4.0.32", features = ["derive"] }
+clap_lex = "=0.3.0"
[features]
# Enable test admin endpoint