summaryrefslogtreecommitdiff
path: root/instrumentation/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'instrumentation/Cargo.toml')
-rw-r--r--instrumentation/Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/instrumentation/Cargo.toml b/instrumentation/Cargo.toml
index 984650a..8ec2fe0 100644
--- a/instrumentation/Cargo.toml
+++ b/instrumentation/Cargo.toml
@@ -3,16 +3,16 @@ name = "instrumentation"
version = "0.1.0"
edition = "2021"
license = "AGPL-3.0-or-later"
-rust-version = "1.70.0"
+rust-version = "1.72.1"
[dependencies]
# Cli args parser
clap = { version = "4.4.6", features = ["derive"] }
-clap_lex = "0.5.1"
+clap_lex = "0.6.0"
common = { path = "../common" }
# Bitcoin
btc-wire = { path = "../btc-wire" }
-bitcoin = { version = "0.30.1", default-features = false, features = ["std"] }
+bitcoin = { version = "0.31.0", default-features = false, features = ["std"] }
# Ethereum
eth-wire = { path = "../eth-wire" }
ethereum-types = { version = "0.14.1", default-features = false }
@@ -32,7 +32,7 @@ color-backtrace = "0.6.0"
# Send signal to child processes
signal-child = "1.0.5"
# Edit toml files
-rust-ini = "0.19.0"
+rust-ini = "0.20.0"
# Progress reporting
indicatif = "0.17.7"
thread-local-panic-hook = "0.1.0"