summaryrefslogtreecommitdiff
path: root/wire-gateway/Cargo.toml
diff options
context:
space:
mode:
authorAntoine A <>2023-10-04 19:46:11 +0200
committerAntoine A <>2023-10-04 19:46:32 +0200
commitb64461c9e5133f63b9edbfb9bb2fc07017a2b735 (patch)
tree56b6db6d2128a731491d62d93c004d1d3561223f /wire-gateway/Cargo.toml
parent1166a20057f4e55416d5c1171726a47d24f11d91 (diff)
downloaddepolymerization-b64461c9e5133f63b9edbfb9bb2fc07017a2b735.tar.gz
depolymerization-b64461c9e5133f63b9edbfb9bb2fc07017a2b735.tar.bz2
depolymerization-b64461c9e5133f63b9edbfb9bb2fc07017a2b735.zip
Update dependencies and bump msrv to 1.70.0 to follow debian unstable package
Diffstat (limited to 'wire-gateway/Cargo.toml')
-rw-r--r--wire-gateway/Cargo.toml20
1 files changed, 10 insertions, 10 deletions
diff --git a/wire-gateway/Cargo.toml b/wire-gateway/Cargo.toml
index 7d6a46e..652e52e 100644
--- a/wire-gateway/Cargo.toml
+++ b/wire-gateway/Cargo.toml
@@ -3,19 +3,19 @@ name = "wire-gateway"
version = "0.1.0"
edition = "2021"
license = "AGPL-3.0-or-later"
-rust-version = "1.63.0"
+rust-version = "1.70.0"
[dependencies]
# Http library
-hyper = { version = "0.14.23", features = ["http1", "server", "runtime"] }
+hyper = { version = "0.14.27", features = ["http1", "server", "runtime"] }
# Hyper compat lib for unix domain socket
hyperlocal = "0.8.0"
# Async runtime
-tokio = { version = "1.24.2", features = ["net", "macros", "rt-multi-thread"] }
+tokio = { version = "1.32.0", features = ["net", "macros", "rt-multi-thread"] }
# Serialization framework
-serde = { version = "1.0.152", features = ["derive"] }
+serde = { version = "1.0.188", features = ["derive"] }
# Serialization helper
-serde_with = "2.2.0"
+serde_with = "3.3.0"
# JSON serialization
serde_json = "1.0.91"
# Url query serialization
@@ -23,21 +23,21 @@ serde_urlencoded = "0.7.1"
# Error macros
thiserror = "1.0.38"
# Deflate compression
-miniz_oxide = "0.6.2"
+miniz_oxide = "0.7.1"
# Async postgres client
tokio-postgres = { version = "0.7.7" }
-deadpool-postgres = "0.10.4"
+deadpool-postgres = "0.11.0"
# Socket activation
listenfd = "1.0.0"
# Common lib
common = { path = "../common" }
# Bitcoin types
-bitcoin = { version = "0.29.2" }
+bitcoin = { version = "0.30.1" }
# Ethereum types
ethereum-types = { version = "0.14.1", default-features = false }
# Cli args parser
-clap = { version = "=4.0.32", features = ["derive"] }
-clap_lex = "=0.3.0"
+clap = { version = "4.4.6", features = ["derive"] }
+clap_lex = "0.5.1"
[features]
# Enable test admin endpoint