summaryrefslogtreecommitdiff
path: root/wire-gateway/Cargo.toml
diff options
context:
space:
mode:
authorAntoine A <>2022-03-04 21:22:32 +0100
committerAntoine A <>2022-03-04 21:22:32 +0100
commita02daa453da90f15ac1033e44ba3aaa54d38d1c3 (patch)
tree678b3dd866ba62d3b08552324fc62046ed304ea2 /wire-gateway/Cargo.toml
parent1e93728aebe96095dde1848e303f07fe9a22daf6 (diff)
downloaddepolymerization-a02daa453da90f15ac1033e44ba3aaa54d38d1c3.tar.gz
depolymerization-a02daa453da90f15ac1033e44ba3aaa54d38d1c3.tar.bz2
depolymerization-a02daa453da90f15ac1033e44ba3aaa54d38d1c3.zip
Improve config parsing
Diffstat (limited to 'wire-gateway/Cargo.toml')
-rw-r--r--wire-gateway/Cargo.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/wire-gateway/Cargo.toml b/wire-gateway/Cargo.toml
index 2104ec4..4015280 100644
--- a/wire-gateway/Cargo.toml
+++ b/wire-gateway/Cargo.toml
@@ -7,17 +7,17 @@ rust-version = "1.56.1"
[dependencies]
# Http library
-hyper = { version = "0.14.16", features = ["http1", "server", "runtime"] }
+hyper = { version = "0.14.17", features = ["http1", "server", "runtime"] }
# Hyper compat lib for unix domain socket
hyperlocal = "0.8.0"
# Async runtime
-tokio = { version = "1.16.1", features = ["net", "macros", "rt-multi-thread"] }
+tokio = { version = "1.17.0", features = ["net", "macros", "rt-multi-thread"] }
# Serialization framework
serde = { version = "1.0.136", features = ["derive"] }
# Serialization helper
-serde_with = "1.11.0"
+serde_with = "1.12.0"
# JSON serialization
-serde_json = "1.0.78"
+serde_json = "1.0.79"
# Url query serialization
serde_urlencoded = "0.7.1"
# Error macros
@@ -34,9 +34,9 @@ common = { path = "../common" }
# Bitcoin types
bitcoin = { version = "0.27.1", optional = true }
# Euthereum types
-ethereum-types = { version = "0.13.0", default-features = false, optional = true }
+ethereum-types = { version = "0.13.1", default-features = false, optional = true }
# Cli args parser
-clap = { version = "3.1.1", features = ["derive"] }
+clap = { version = "3.1.5", features = ["derive"] }
[features]
default = ["btc", "eth"]