summaryrefslogtreecommitdiff
path: root/wire-gateway/Cargo.toml
diff options
context:
space:
mode:
authorAntoine A <>2021-11-22 14:25:46 +0100
committerAntoine A <>2021-11-22 14:25:46 +0100
commit8f7c61d1dd3c5116ad69f73a57fa54a52254f37f (patch)
tree7b94a720bf9459b9b3130602319f48f78d7f6800 /wire-gateway/Cargo.toml
parent2e04d71b925c02e6a2d33c82cd248492b4ac5967 (diff)
downloaddepolymerization-8f7c61d1dd3c5116ad69f73a57fa54a52254f37f.tar.gz
depolymerization-8f7c61d1dd3c5116ad69f73a57fa54a52254f37f.tar.bz2
depolymerization-8f7c61d1dd3c5116ad69f73a57fa54a52254f37f.zip
Draft wire gateway API
Diffstat (limited to 'wire-gateway/Cargo.toml')
-rw-r--r--wire-gateway/Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/wire-gateway/Cargo.toml b/wire-gateway/Cargo.toml
new file mode 100644
index 0000000..0841dd9
--- /dev/null
+++ b/wire-gateway/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "wire-gateway"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+# Http library
+hyper = { version = "0.14.15", features = ["http1", "server", "runtime"] }
+# Async runtime
+tokio = { version = "1.14.0", features = ["full"] }
+# Serialization framework
+serde = { version = "1.0.130", features = ["derive"] }
+# Serialization helper
+serde_with = "1.11.0"
+# JSON serialization
+serde_json = "1.0.71"
+# Crockford’s base32
+base32 = "0.4.0"
+# Error macros
+thiserror = "1.0.30"