summaryrefslogtreecommitdiff
path: root/wire-gateway/Cargo.toml
diff options
context:
space:
mode:
authorAntoine A <>2022-01-04 20:25:02 +0100
committerAntoine A <>2022-01-04 20:25:02 +0100
commit5f97609307dd96c3b0dca2a5f61f914fb9057f96 (patch)
tree071fdfef1e121d979c7ea090cce4499a00ef5337 /wire-gateway/Cargo.toml
parent7f443715468c292d84c4a0c54942aab550120cfb (diff)
downloaddepolymerization-5f97609307dd96c3b0dca2a5f61f914fb9057f96.tar.gz
depolymerization-5f97609307dd96c3b0dca2a5f61f914fb9057f96.tar.bz2
depolymerization-5f97609307dd96c3b0dca2a5f61f914fb9057f96.zip
Update dependencies and add support for unix domain socket
Diffstat (limited to 'wire-gateway/Cargo.toml')
-rw-r--r--wire-gateway/Cargo.toml10
1 files changed, 6 insertions, 4 deletions
diff --git a/wire-gateway/Cargo.toml b/wire-gateway/Cargo.toml
index 902101e..46db7bb 100644
--- a/wire-gateway/Cargo.toml
+++ b/wire-gateway/Cargo.toml
@@ -9,15 +9,17 @@ test = []
[dependencies]
# Http library
-hyper = { version = "0.14.15", features = ["http1", "server", "runtime"] }
+hyper = { version = "0.14.16", features = ["http1", "server", "runtime"] }
+# Hyper compat lib for unix domain socket
+hyperlocal = "0.8.0"
# Async runtime
-tokio = { version = "1.14.0", features = ["net", "macros", "rt-multi-thread"] }
+tokio = { version = "1.15.0", features = ["net", "macros", "rt-multi-thread"] }
# Serialization framework
-serde = { version = "1.0.130", features = ["derive"] }
+serde = { version = "1.0", features = ["derive"] }
# Serialization helper
serde_with = "1.11.0"
# JSON serialization
-serde_json = "1.0.72"
+serde_json = "1.0"
# Url query serialization
serde_urlencoded = "0.7.0"
# Error macros