aboutsummaryrefslogtreecommitdiff
path: root/btc-wire/Cargo.toml
diff options
context:
space:
mode:
authorAntoine A <>2021-11-30 12:25:14 +0100
committerAntoine A <>2021-11-30 12:25:14 +0100
commitf0133d33be5b1666d20b640c57a497bc239caba5 (patch)
tree644af0e607c3fab1d0d8f01fc10d7b803dc53e9b /btc-wire/Cargo.toml
parent491410969b1fec9c0e01def555a970f02c3d76af (diff)
downloaddepolymerization-f0133d33be5b1666d20b640c57a497bc239caba5.tar.gz
depolymerization-f0133d33be5b1666d20b640c57a497bc239caba5.tar.bz2
depolymerization-f0133d33be5b1666d20b640c57a497bc239caba5.zip
Rename refund to bounce and improve error handling
Diffstat (limited to 'btc-wire/Cargo.toml')
-rw-r--r--btc-wire/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/btc-wire/Cargo.toml b/btc-wire/Cargo.toml
index d63d995..a8416f4 100644
--- a/btc-wire/Cargo.toml
+++ b/btc-wire/Cargo.toml
@@ -20,6 +20,8 @@ fastrand = "1.5.0"
serde = { version = "1.0.130", features = ["derive"] }
# Zero allocation terminal color
owo-colors = "3.1.0"
+# Error macros
+thiserror = "1.0.30"
[dev-dependencies]
# statistics-driven micro-benchmarks