aboutsummaryrefslogtreecommitdiff
path: root/btc-wire/Cargo.toml
diff options
context:
space:
mode:
authorAntoine A <>2021-12-02 18:26:49 +0100
committerAntoine A <>2021-12-02 18:26:49 +0100
commitc1cfa0e5a18a8cd2455eb8fb115f71f8841e3168 (patch)
treeb50a9b11c16525afd7739f1524a1477e974c2acb /btc-wire/Cargo.toml
parent029cae75e52654c51daa671cec151874ce93a448 (diff)
downloaddepolymerization-c1cfa0e5a18a8cd2455eb8fb115f71f8841e3168.tar.gz
depolymerization-c1cfa0e5a18a8cd2455eb8fb115f71f8841e3168.tar.bz2
depolymerization-c1cfa0e5a18a8cd2455eb8fb115f71f8841e3168.zip
Refactor to new architecture
Diffstat (limited to 'btc-wire/Cargo.toml')
-rw-r--r--btc-wire/Cargo.toml12
1 files changed, 8 insertions, 4 deletions
diff --git a/btc-wire/Cargo.toml b/btc-wire/Cargo.toml
index f7e25fe..eb3b632 100644
--- a/btc-wire/Cargo.toml
+++ b/btc-wire/Cargo.toml
@@ -8,8 +8,6 @@ edition = "2021"
bitcoincore-rpc = "0.14.0"
# Cli args
argh = "0.1.6"
-# Readline
-rustyline = "9.0.0"
# Bech32 encoding and decoding
bech32 = "0.8.1"
# Secure random
@@ -18,10 +16,16 @@ rand = { version = "0.8.4", features = ["getrandom"] }
fastrand = "1.5.0"
# Serialization library
serde = { version = "1.0.130", features = ["derive"] }
-# Zero allocation terminal color
-owo-colors = "3.1.0"
# Error macros
thiserror = "1.0.30"
+# Postgres client
+postgres = "0.19.2"
+# Optimized uri binary format
+uri-pack = { path = "../uri-pack" }
+# Url format
+url = { version = "2.2.2", features = ["serde"] }
+# Wire gateway api
+wire-gateway = { path = "../wire-gateway" }
[dev-dependencies]
# statistics-driven micro-benchmarks