summaryrefslogtreecommitdiff
path: root/btc-wire/Cargo.toml
diff options
context:
space:
mode:
authorAntoine A <>2021-12-16 17:35:19 +0100
committerAntoine A <>2021-12-16 21:45:16 +0100
commit92c4d2638fd272de0b60d759bdbc9f1ada01e27c (patch)
tree3a14b5a221b941f9c7e85a39b67e2d05441d897c /btc-wire/Cargo.toml
parent1be9da930bd1d532109490a15fb97c27c52ce3ce (diff)
downloaddepolymerization-92c4d2638fd272de0b60d759bdbc9f1ada01e27c.tar.gz
depolymerization-92c4d2638fd272de0b60d759bdbc9f1ada01e27c.tar.bz2
depolymerization-92c4d2638fd272de0b60d759bdbc9f1ada01e27c.zip
Use custom simple RPC client
Diffstat (limited to 'btc-wire/Cargo.toml')
-rw-r--r--btc-wire/Cargo.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/btc-wire/Cargo.toml b/btc-wire/Cargo.toml
index 3d97a06..9f3c8c2 100644
--- a/btc-wire/Cargo.toml
+++ b/btc-wire/Cargo.toml
@@ -8,8 +8,8 @@ edition = "2021"
fail = []
[dependencies]
-# Typed bitcoin json-rpc library
-bitcoincore-rpc = "0.14.0"
+# Typed bitcoin rpc types
+bitcoincore-rpc-json = "0.14.0"
# Cli args
argh = "0.1.6"
# Bech32 encoding and decoding
@@ -20,6 +20,8 @@ rand = { version = "0.8.4", features = ["getrandom"] }
fastrand = "1.5.0"
# Serialization library
serde = { version = "1.0.130", features = ["derive"] }
+serde_json = "1.0.66"
+serde_repr = "0.1"
# Error macros
thiserror = "1.0.30"
# Postgres client
@@ -30,6 +32,8 @@ uri-pack = { path = "../uri-pack" }
url = { version = "2.2.2", features = ["serde"] }
# Ansi color
owo-colors = "3.1.1"
+ureq = { version = "2.3.1", features = ["json"] }
+base64 = "0.13.0"
# Taler libs
taler-api = { path = "../taler-api" }
taler-config = { path = "../taler-config" }