aboutsummaryrefslogtreecommitdiff
path: root/btc-wire/Cargo.toml
diff options
context:
space:
mode:
authorAntoine A <>2022-02-15 16:05:04 +0100
committerAntoine A <>2022-02-15 16:58:41 +0100
commit88556bdbfa2140e8d11367cf87601df0c70f0604 (patch)
tree39ad5eed91fb8d074c5fa668840d533bfbe43616 /btc-wire/Cargo.toml
parent187f435336d86935a92b4d55a5a17cd5e24b9aab (diff)
downloaddepolymerization-88556bdbfa2140e8d11367cf87601df0c70f0604.tar.gz
depolymerization-88556bdbfa2140e8d11367cf87601df0c70f0604.tar.bz2
depolymerization-88556bdbfa2140e8d11367cf87601df0c70f0604.zip
Replace argh CLI parser with clap, merge wire binary with its bootstrap and improve config error msg
Diffstat (limited to 'btc-wire/Cargo.toml')
-rw-r--r--btc-wire/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/btc-wire/Cargo.toml b/btc-wire/Cargo.toml
index 6580fda..243d045 100644
--- a/btc-wire/Cargo.toml
+++ b/btc-wire/Cargo.toml
@@ -15,8 +15,8 @@ bitcoin = { version = "0.27.1", features = [
"std",
"use-serde",
], default-features = false }
-# Cli args
-argh = "0.1.7"
+# Cli args parser
+clap = { version = "3.0.14", features = ["derive"] }
# Bech32 encoding and decoding
bech32 = "0.8.1"
# Serialization library