summaryrefslogtreecommitdiff
path: root/btc-wire/Cargo.toml
diff options
context:
space:
mode:
authorAntoine A <>2023-01-24 15:38:45 +0100
committerAntoine A <>2023-01-24 15:38:45 +0100
commit67c682100c7efcf58d53418c45e6611e5f6eab82 (patch)
tree0f2b5b95cb581e8e133e43aef338463721795c5d /btc-wire/Cargo.toml
parent4f2696c5fc72f2ba07ba5a5b4c9e51e1237d2a92 (diff)
downloaddepolymerization-67c682100c7efcf58d53418c45e6611e5f6eab82.tar.gz
depolymerization-67c682100c7efcf58d53418c45e6611e5f6eab82.tar.bz2
depolymerization-67c682100c7efcf58d53418c45e6611e5f6eab82.zip
Update dependencies
Diffstat (limited to 'btc-wire/Cargo.toml')
-rw-r--r--btc-wire/Cargo.toml13
1 files changed, 7 insertions, 6 deletions
diff --git a/btc-wire/Cargo.toml b/btc-wire/Cargo.toml
index 7be17c0..91d3722 100644
--- a/btc-wire/Cargo.toml
+++ b/btc-wire/Cargo.toml
@@ -16,16 +16,17 @@ bitcoin = { version = "0.29.2", features = [
"serde",
], default-features = false }
# Cli args parser
-clap = { version = "4.0.29", features = ["derive"] }
+clap = { version = "=4.0.32", features = ["derive"] }
+clap_lex = "=0.3.0"
# Bech32 encoding and decoding
bech32 = "0.9.1"
# Serialization library
-serde = { version = "1.0.149", features = ["derive"] }
-serde_json = "1.0.89"
-serde_repr = "0.1.9"
+serde = { version = "1.0.152", features = ["derive"] }
+serde_json = "1.0.91"
+serde_repr = "0.1.10"
# Error macros
-thiserror = "1.0.37"
-base64 = "0.20.0"
+thiserror = "1.0.38"
+base64 = "0.21.0"
# Common lib
common = { path = "../common" }
# Ini parser