aboutsummaryrefslogtreecommitdiff
path: root/tools/gyp/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'tools/gyp/setup.py')
-rwxr-xr-xtools/gyp/setup.py11
1 files changed, 2 insertions, 9 deletions
diff --git a/tools/gyp/setup.py b/tools/gyp/setup.py
index ed2b41a3c3..75a42558d8 100755
--- a/tools/gyp/setup.py
+++ b/tools/gyp/setup.py
@@ -4,10 +4,7 @@
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
-from distutils.core import setup
-from distutils.command.install import install
-from distutils.command.install_lib import install_lib
-from distutils.command.install_scripts import install_scripts
+from setuptools import setup
setup(
name='gyp',
@@ -18,9 +15,5 @@ setup(
url='http://code.google.com/p/gyp',
package_dir = {'': 'pylib'},
packages=['gyp', 'gyp.generator'],
-
- scripts = ['gyp'],
- cmdclass = {'install': install,
- 'install_lib': install_lib,
- 'install_scripts': install_scripts},
+ entry_points = {'console_scripts': ['gyp=gyp:script_main'] }
)