summaryrefslogtreecommitdiff
path: root/deps/uv/configure.ac
diff options
context:
space:
mode:
authorcjihrig <cjihrig@gmail.com>2019-08-09 11:03:55 -0400
committercjihrig <cjihrig@gmail.com>2019-08-11 11:22:01 -0400
commitce7f3ed13ca15ae4c166d922e7ee39ad2ef41abb (patch)
treef25ca8d612ee2bdfb78f2bac31439633dfb2bb3d /deps/uv/configure.ac
parent8ef68e66d0465441a79a5dae22e480bf0d83ed25 (diff)
downloadandroid-node-v8-ce7f3ed13ca15ae4c166d922e7ee39ad2ef41abb.tar.gz
android-node-v8-ce7f3ed13ca15ae4c166d922e7ee39ad2ef41abb.tar.bz2
android-node-v8-ce7f3ed13ca15ae4c166d922e7ee39ad2ef41abb.zip
deps: upgrade to libuv 1.31.0
Notable changes: - UV_FS_O_FILEMAP has been added for faster access to memory mapped files on Windows. - uv_fs_mkdir() now returns UV_EINVAL for invalid filenames on Windows. It previously returned UV_ENOENT. - The uv_fs_statfs() API has been added. - The uv_os_environ() and uv_os_free_environ() APIs have been added. Fixes: https://github.com/nodejs/node/issues/28599 Fixes: https://github.com/nodejs/node/issues/28945 Fixes: https://github.com/nodejs/node/issues/29008 PR-URL: https://github.com/nodejs/node/pull/29070 Reviewed-By: Richard Lau <riclau@uk.ibm.com> Reviewed-By: Trivikram Kamat <trivikr.dev@gmail.com> Reviewed-By: Rich Trott <rtrott@gmail.com> Reviewed-By: Ben Noordhuis <info@bnoordhuis.nl> Reviewed-By: Jiawen Geng <technicalcute@gmail.com>
Diffstat (limited to 'deps/uv/configure.ac')
-rw-r--r--deps/uv/configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/deps/uv/configure.ac b/deps/uv/configure.ac
index 52aaddcfc1..c5e29fef84 100644
--- a/deps/uv/configure.ac
+++ b/deps/uv/configure.ac
@@ -13,7 +13,7 @@
# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
AC_PREREQ(2.57)
-AC_INIT([libuv], [1.30.1], [https://github.com/libuv/libuv/issues])
+AC_INIT([libuv], [1.31.0], [https://github.com/libuv/libuv/issues])
AC_CONFIG_MACRO_DIR([m4])
m4_include([m4/libuv-extra-automake-flags.m4])
m4_include([m4/as_case.m4])
@@ -63,6 +63,7 @@ AM_CONDITIONAL([MSYS], [AS_CASE([$host_os],[msys*], [true], [false])
AM_CONDITIONAL([NETBSD], [AS_CASE([$host_os],[netbsd*], [true], [false])])
AM_CONDITIONAL([OPENBSD], [AS_CASE([$host_os],[openbsd*], [true], [false])])
AM_CONDITIONAL([OS390], [AS_CASE([$host_os],[openedition*], [true], [false])])
+AM_CONDITIONAL([OS400], [AS_CASE([$host_os],[os400], [true], [false])])
AM_CONDITIONAL([SUNOS], [AS_CASE([$host_os],[solaris*], [true], [false])])
AM_CONDITIONAL([WINNT], [AS_CASE([$host_os],[mingw*], [true], [false])])
AS_CASE([$host_os],[mingw*], [