summaryrefslogtreecommitdiff
path: root/deps/uv/configure.ac
diff options
context:
space:
mode:
authorcjihrig <cjihrig@gmail.com>2019-10-19 16:46:32 -0500
committercjihrig <cjihrig@gmail.com>2019-10-20 10:13:31 -0500
commit7d433a936bce26707f7a10bb56b121fe0dfb0a66 (patch)
treeee46549068d0ba1c62b2cca0a9036182d70e0682 /deps/uv/configure.ac
parent0822bfaa9f52aea289abd0e15a90b0df2e12f7e1 (diff)
downloadandroid-node-v8-7d433a936bce26707f7a10bb56b121fe0dfb0a66.tar.gz
android-node-v8-7d433a936bce26707f7a10bb56b121fe0dfb0a66.tar.bz2
android-node-v8-7d433a936bce26707f7a10bb56b121fe0dfb0a66.zip
deps: upgrade to libuv 1.33.1
Notable changes: - uv_random() has been added. - More work to read those pesky Windows environment variables. - Several build fixes for Tier 3 platforms (Android, NetBSD, OpenBSD, Haiku). - Stop using fsevents to watch files (using kqueue again). PR-URL: https://github.com/nodejs/node/pull/29996 Reviewed-By: Richard Lau <riclau@uk.ibm.com> Reviewed-By: Anna Henningsen <anna@addaleax.net> Reviewed-By: David Carlier <devnexen@gmail.com> Reviewed-By: Trivikram Kamat <trivikr.dev@gmail.com> Reviewed-By: Jiawen Geng <technicalcute@gmail.com> Reviewed-By: James M Snell <jasnell@gmail.com> Reviewed-By: Gireesh Punathil <gpunathi@in.ibm.com>
Diffstat (limited to 'deps/uv/configure.ac')
-rw-r--r--deps/uv/configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/deps/uv/configure.ac b/deps/uv/configure.ac
index b503e53829..07ad0cde81 100644
--- a/deps/uv/configure.ac
+++ b/deps/uv/configure.ac
@@ -13,7 +13,7 @@
# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
AC_PREREQ(2.57)
-AC_INIT([libuv], [1.32.0], [https://github.com/libuv/libuv/issues])
+AC_INIT([libuv], [1.33.1], [https://github.com/libuv/libuv/issues])
AC_CONFIG_MACRO_DIR([m4])
m4_include([m4/libuv-extra-automake-flags.m4])
m4_include([m4/as_case.m4])
@@ -32,6 +32,7 @@ CC_CHECK_CFLAGS_APPEND([-g])
CC_CHECK_CFLAGS_APPEND([-std=gnu89])
CC_CHECK_CFLAGS_APPEND([-Wall])
CC_CHECK_CFLAGS_APPEND([-Wextra])
+CC_CHECK_CFLAGS_APPEND([-Wno-long-long])
CC_CHECK_CFLAGS_APPEND([-Wno-unused-parameter])
CC_CHECK_CFLAGS_APPEND([-Wstrict-prototypes])
# AM_PROG_AR is not available in automake v0.11 but it's essential in v0.12.
@@ -80,4 +81,5 @@ AC_CHECK_HEADERS([sys/ahafs_evProds.h])
AC_CONFIG_FILES([Makefile libuv.pc])
AC_CONFIG_LINKS([test/fixtures/empty_file:test/fixtures/empty_file])
AC_CONFIG_LINKS([test/fixtures/load_error.node:test/fixtures/load_error.node])
+AC_CONFIG_LINKS([test/fixtures/lorem_ipsum.txt:test/fixtures/lorem_ipsum.txt])
AC_OUTPUT