summaryrefslogtreecommitdiff
path: root/deps/uv/Makefile.am
diff options
context:
space:
mode:
authorFedor Indutny <fedor.indutny@gmail.com>2013-12-13 22:35:09 +0400
committerFedor Indutny <fedor.indutny@gmail.com>2013-12-13 22:35:09 +0400
commitf61d9405bfcf0fa113a13d57d41fef7d74a69538 (patch)
tree9618cb7ae2285c51ff6f73cdfb8356537d55e9e6 /deps/uv/Makefile.am
parent069dd07a1732c6a752773aaed9e8c18ab472375f (diff)
downloadandroid-node-v8-f61d9405bfcf0fa113a13d57d41fef7d74a69538.tar.gz
android-node-v8-f61d9405bfcf0fa113a13d57d41fef7d74a69538.tar.bz2
android-node-v8-f61d9405bfcf0fa113a13d57d41fef7d74a69538.zip
uv: Upgrade to v0.11.16
Diffstat (limited to 'deps/uv/Makefile.am')
-rw-r--r--deps/uv/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/deps/uv/Makefile.am b/deps/uv/Makefile.am
index 8f656f36f4..2229e86f3d 100644
--- a/deps/uv/Makefile.am
+++ b/deps/uv/Makefile.am
@@ -126,6 +126,7 @@ test_run_tests_SOURCES = test/blackhole-server.c \
test/test-delayed-accept.c \
test/test-dlerror.c \
test/test-embed.c \
+ test/test-emfile.c \
test/test-error.c \
test/test-fail-always.c \
test/test-fs-event.c \
@@ -138,12 +139,14 @@ test_run_tests_SOURCES = test/blackhole-server.c \
test/test-getsockname.c \
test/test-hrtime.c \
test/test-idle.c \
+ test/test-ip4-addr.c \
test/test-ip6-addr.c \
test/test-ipc-send-recv.c \
test/test-ipc.c \
test/test-list.h \
test/test-loop-handles.c \
test/test-loop-stop.c \
+ test/test-loop-time.c \
test/test-multiple-listen.c \
test/test-mutexes.c \
test/test-osx-select.c \
@@ -181,6 +184,7 @@ test_run_tests_SOURCES = test/blackhole-server.c \
test/test-tcp-unexpected-read.c \
test/test-tcp-write-to-half-open-connection.c \
test/test-tcp-writealot.c \
+ test/test-tcp-try-write.c \
test/test-thread.c \
test/test-threadpool-cancel.c \
test/test-threadpool.c \
@@ -266,10 +270,18 @@ libuv_la_LIBADD = uv-dtrace.lo
CLEANFILES += src/unix/uv-dtrace.o src/unix/uv-dtrace.lo
endif
-SUFFIXES = .d
+if HAVE_PKG_CONFIG
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = @PACKAGE_NAME@.pc
+endif
+if HAVE_DTRACE
include/uv-dtrace.h: src/unix/uv-dtrace.d
$(AM_V_GEN)$(DTRACE) $(DTRACEFLAGS) -h -xnolibs -s $< -o $(top_srcdir)/$@
+endif
+
+if DTRACE_NEEDS_OBJECTS
+SUFFIXES = .d
src/unix/uv-dtrace.o: src/unix/uv-dtrace.d ${libuv_la_OBJECTS}
@@ -285,3 +297,4 @@ src/unix/uv-dtrace.o: src/unix/uv-dtrace.d ${libuv_la_OBJECTS}
"pic_object='uv-dtrace.o'" \
"non_pic_object='uv-dtrace.o'" \
> ${top_builddir}/uv-dtrace.lo
+endif