summaryrefslogtreecommitdiff
path: root/deps/uv/Makefile.am
diff options
context:
space:
mode:
authorFedor Indutny <fedor@indutny.com>2014-08-07 15:03:17 +0400
committerFedor Indutny <fedor@indutny.com>2014-08-07 15:03:17 +0400
commite49429ebd2fe0b7c24e2ee533311dd97f6febd1f (patch)
treed958c7f24638bc13ce3f17211e914828bad2fc85 /deps/uv/Makefile.am
parentaa3b4b4d106415b3afbc31df0db2476a04c997f1 (diff)
downloadandroid-node-v8-e49429ebd2fe0b7c24e2ee533311dd97f6febd1f.tar.gz
android-node-v8-e49429ebd2fe0b7c24e2ee533311dd97f6febd1f.tar.bz2
android-node-v8-e49429ebd2fe0b7c24e2ee533311dd97f6febd1f.zip
deps: update libuv to v0.11.28
Diffstat (limited to 'deps/uv/Makefile.am')
-rw-r--r--deps/uv/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/deps/uv/Makefile.am b/deps/uv/Makefile.am
index ebcd8db2e2..861b632bbf 100644
--- a/deps/uv/Makefile.am
+++ b/deps/uv/Makefile.am
@@ -17,7 +17,7 @@ ACLOCAL_AMFLAGS = -I m4
AM_CPPFLAGS = -I$(top_srcdir)/include \
-I$(top_srcdir)/src
-include_HEADERS=include/uv.h include/uv-errno.h include/uv-version.h
+include_HEADERS=include/uv.h include/uv-errno.h include/uv-threadpool.h include/uv-version.h
CLEANFILES =
@@ -28,6 +28,7 @@ libuv_la_SOURCES = src/fs-poll.c \
src/heap-inl.h \
src/inet.c \
src/queue.h \
+ src/threadpool.c \
src/uv-common.c \
src/uv-common.h \
src/version.c
@@ -67,7 +68,6 @@ libuv_la_SOURCES += src/win/async.c \
src/win/stream-inl.h \
src/win/tcp.c \
src/win/thread.c \
- src/win/threadpool.c \
src/win/timer.c \
src/win/tty.c \
src/win/udp.c \
@@ -99,7 +99,6 @@ libuv_la_SOURCES += src/unix/async.c \
src/unix/stream.c \
src/unix/tcp.c \
src/unix/thread.c \
- src/unix/threadpool.c \
src/unix/timer.c \
src/unix/tty.c \
src/unix/udp.c
@@ -197,6 +196,7 @@ test_run_tests_SOURCES = test/blackhole-server.c \
test/test-tcp-write-to-half-open-connection.c \
test/test-tcp-writealot.c \
test/test-tcp-try-write.c \
+ test/test-tcp-write-queue-order.c \
test/test-thread.c \
test/test-threadpool-cancel.c \
test/test-threadpool.c \
@@ -215,6 +215,8 @@ test_run_tests_SOURCES = test/blackhole-server.c \
test/test-udp-open.c \
test/test-udp-options.c \
test/test-udp-send-and-recv.c \
+ test/test-udp-send-immediate.c \
+ test/test-udp-try-send.c \
test/test-walk-handles.c \
test/test-watcher-cross-stop.c
test_run_tests_LDADD = libuv.la
@@ -228,7 +230,7 @@ test_run_tests_SOURCES += test/runner-unix.c \
endif
if AIX
-test_run_tests_CFLAGS += -D_ALL_SOURCE -D_XOPEN_SOURCE=500
+test_run_tests_CFLAGS += -D_ALL_SOURCE -D_XOPEN_SOURCE=500 -D_LINUX_SOURCE_COMPAT
endif
if SUNOS
@@ -237,7 +239,7 @@ endif
if AIX
-libuv_la_CFLAGS += -D_ALL_SOURCE -D_XOPEN_SOURCE=500
+libuv_la_CFLAGS += -D_ALL_SOURCE -D_XOPEN_SOURCE=500 -D_LINUX_SOURCE_COMPAT
libuv_la_SOURCES += src/unix/aix.c
endif