summaryrefslogtreecommitdiff
path: root/deps/uv/Makefile.am
diff options
context:
space:
mode:
authorcjihrig <cjihrig@gmail.com>2019-03-16 14:38:18 -0400
committercjihrig <cjihrig@gmail.com>2019-03-18 14:42:24 -0400
commitd6f6d7f8541327b72667d38777c47b9ea675125d (patch)
treebabcc15f478453e5a7a426f1227c3372cb79e869 /deps/uv/Makefile.am
parent04f30e1a7a5a2f49b611314578758e2009ec2152 (diff)
downloadandroid-node-v8-d6f6d7f8541327b72667d38777c47b9ea675125d.tar.gz
android-node-v8-d6f6d7f8541327b72667d38777c47b9ea675125d.tar.bz2
android-node-v8-d6f6d7f8541327b72667d38777c47b9ea675125d.zip
deps: upgrade to libuv 1.27.0
Notable changes: - `statx()` is used to retrieve file birth times on supported platforms. - Improved support of running under Windows safe mode. - Add support for UDP connected sockets. Several functions can now return `UV_EBADF` instead of `UV_EINVAL`. - SunOS support is improved. PR-URL: https://github.com/nodejs/node/pull/26707 Reviewed-By: Santiago Gimeno <santiago.gimeno@gmail.com> Reviewed-By: Anna Henningsen <anna@addaleax.net> Reviewed-By: Richard Lau <riclau@uk.ibm.com> Reviewed-By: Refael Ackermann <refack@gmail.com> Reviewed-By: Ruben Bridgewater <ruben@bridgewater.de> Reviewed-By: James M Snell <jasnell@gmail.com>
Diffstat (limited to 'deps/uv/Makefile.am')
-rw-r--r--deps/uv/Makefile.am24
1 files changed, 20 insertions, 4 deletions
diff --git a/deps/uv/Makefile.am b/deps/uv/Makefile.am
index 7e49d8ad0b..595a5aea03 100644
--- a/deps/uv/Makefile.am
+++ b/deps/uv/Makefile.am
@@ -32,6 +32,7 @@ libuv_la_LDFLAGS = -no-undefined -version-info 1:0:0
libuv_la_SOURCES = src/fs-poll.c \
src/heap-inl.h \
src/idna.c \
+ src/idna.h \
src/inet.c \
src/queue.h \
src/strscpy.c \
@@ -44,10 +45,12 @@ libuv_la_SOURCES = src/fs-poll.c \
src/version.c
if SUNOS
+if GCC
# Can't be turned into a CC_CHECK_CFLAGS in configure.ac, it makes compilers
# on other platforms complain that the argument is unused during compilation.
libuv_la_CFLAGS += -pthreads
endif
+endif
if WINNT
@@ -121,11 +124,13 @@ EXTRA_DIST = test/fixtures/empty_file \
docs \
img \
samples \
- android-configure \
+ android-configure-arm \
+ android-configure-arm64 \
+ android-configure-x86 \
+ android-configure-x86_64 \
CONTRIBUTING.md \
LICENSE \
README.md \
- checksparse.sh \
vcbuild.bat \
common.gypi \
gyp_uv.py \
@@ -138,14 +143,20 @@ check_PROGRAMS = test/run-tests
if OS390
test_run_tests_CFLAGS =
else
+if GCC
test_run_tests_CFLAGS = -Wno-long-long
+else
+test_run_tests_CFLAGS =
+endif
endif
if SUNOS
+if GCC
# Can't be turned into a CC_CHECK_CFLAGS in configure.ac, it makes compilers
# on other platforms complain that the argument is unused during compilation.
test_run_tests_CFLAGS += -pthreads
endif
+endif
test_run_tests_LDFLAGS =
test_run_tests_SOURCES = test/blackhole-server.c \
@@ -281,6 +292,7 @@ test_run_tests_SOURCES = test/blackhole-server.c \
test/test-tty.c \
test/test-udp-alloc-cb-fail.c \
test/test-udp-bind.c \
+ test/test-udp-connect.c \
test/test-udp-create-socket-early.c \
test/test-udp-dgram-too-big.c \
test/test-udp-ipv6.c \
@@ -320,7 +332,9 @@ test_run_tests_CFLAGS += -D_GNU_SOURCE
endif
if SUNOS
-test_run_tests_CFLAGS += -D__EXTENSIONS__ -D_XOPEN_SOURCE=500
+test_run_tests_CFLAGS += -D__EXTENSIONS__ \
+ -D_XOPEN_SOURCE=500 \
+ -D_REENTRANT
endif
if OS390
@@ -458,7 +472,9 @@ endif
if SUNOS
uvinclude_HEADERS += include/uv/sunos.h
-libuv_la_CFLAGS += -D__EXTENSIONS__ -D_XOPEN_SOURCE=500
+libuv_la_CFLAGS += -D__EXTENSIONS__ \
+ -D_XOPEN_SOURCE=500 \
+ -D_REENTRANT
libuv_la_SOURCES += src/unix/no-proctitle.c \
src/unix/sunos.c
endif