summaryrefslogtreecommitdiff
path: root/deps/uv/Makefile.am
diff options
context:
space:
mode:
authorcjihrig <cjihrig@gmail.com>2018-01-19 15:33:43 -0500
committercjihrig <cjihrig@gmail.com>2018-01-23 20:34:39 -0500
commita083786c7733b5828102661a04a86884c934950a (patch)
treea45536a61b50e7b5fa68a77d6f594de730c4a346 /deps/uv/Makefile.am
parent63f78f5ddc8ac50ea19839827682c51ff3363ac2 (diff)
downloadandroid-node-v8-a083786c7733b5828102661a04a86884c934950a.tar.gz
android-node-v8-a083786c7733b5828102661a04a86884c934950a.tar.bz2
android-node-v8-a083786c7733b5828102661a04a86884c934950a.zip
deps: upgrade libuv to 1.19.1
PR-URL: https://github.com/nodejs/node/pull/18260 Reviewed-By: James M Snell <jasnell@gmail.com>
Diffstat (limited to 'deps/uv/Makefile.am')
-rw-r--r--deps/uv/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/deps/uv/Makefile.am b/deps/uv/Makefile.am
index e01cf41663..ae9d96bcf6 100644
--- a/deps/uv/Makefile.am
+++ b/deps/uv/Makefile.am
@@ -29,6 +29,7 @@ libuv_la_SOURCES = src/fs-poll.c \
src/inet.c \
src/queue.h \
src/threadpool.c \
+ src/uv-data-getter-setters.c \
src/uv-common.c \
src/uv-common.h \
src/version.c
@@ -158,6 +159,7 @@ test_run_tests_SOURCES = test/blackhole-server.c \
test/test-close-fd.c \
test/test-close-order.c \
test/test-condvar.c \
+ test/test-connect-unspecified.c \
test/test-connection-fail.c \
test/test-cwd-and-chdir.c \
test/test-default-loop-close.c \
@@ -174,6 +176,7 @@ test_run_tests_SOURCES = test/blackhole-server.c \
test/test-fs-poll.c \
test/test-fs.c \
test/test-fork.c \
+ test/test-getters-setters.c \
test/test-get-currentexe.c \
test/test-get-loadavg.c \
test/test-get-memory.c \
@@ -220,6 +223,7 @@ test_run_tests_SOURCES = test/blackhole-server.c \
test/test-poll-closesocket.c \
test/test-poll-oob.c \
test/test-process-title.c \
+ test/test-process-title-threadsafe.c \
test/test-queue-foreach-delete.c \
test/test-ref.c \
test/test-run-nowait.c \
@@ -455,13 +459,10 @@ libuv_la_CFLAGS += -D_UNIX03_THREADS \
-qFLOAT=IEEE
libuv_la_LDFLAGS += -qXPLINK
libuv_la_SOURCES += src/unix/pthread-fixes.c \
- src/unix/no-fsevents.c \
src/unix/os390.c \
src/unix/os390-syscalls.c \
src/unix/proctitle.c
endif
-if HAVE_PKG_CONFIG
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = @PACKAGE_NAME@.pc
-endif