summaryrefslogtreecommitdiff
path: root/deps/uv/Makefile.am
diff options
context:
space:
mode:
authorFedor Indutny <fedor@indutny.com>2014-04-07 16:36:51 +0400
committerFedor Indutny <fedor@indutny.com>2014-04-07 16:36:51 +0400
commit962f96d3416ee00c78e729bc1c1b05e02d0c1ef2 (patch)
tree54b04b551eaa04e280f416b106c0de5c29b39bda /deps/uv/Makefile.am
parent95dbb6bf647d90947c0c738533dadf391559be98 (diff)
downloadandroid-node-v8-962f96d3416ee00c78e729bc1c1b05e02d0c1ef2.tar.gz
android-node-v8-962f96d3416ee00c78e729bc1c1b05e02d0c1ef2.tar.bz2
android-node-v8-962f96d3416ee00c78e729bc1c1b05e02d0c1ef2.zip
deps: update libuv to v0.11.23
Diffstat (limited to 'deps/uv/Makefile.am')
-rw-r--r--deps/uv/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/deps/uv/Makefile.am b/deps/uv/Makefile.am
index 3aa40c6111..41833c9822 100644
--- a/deps/uv/Makefile.am
+++ b/deps/uv/Makefile.am
@@ -106,6 +106,7 @@ endif # WINNT
TESTS = test/run-tests
check_PROGRAMS = test/run-tests
+test_run_tests_CFLAGS =
test_run_tests_SOURCES = test/blackhole-server.c \
test/dns-server.c \
test/echo-server.c \
@@ -199,10 +200,13 @@ test_run_tests_SOURCES = test/blackhole-server.c \
test/test-timer-from-check.c \
test/test-timer.c \
test/test-tty.c \
+ test/test-udp-bind.c \
test/test-udp-dgram-too-big.c \
test/test-udp-ipv6.c \
test/test-udp-multicast-interface.c \
+ test/test-udp-multicast-interface6.c \
test/test-udp-multicast-join.c \
+ test/test-udp-multicast-join6.c \
test/test-udp-multicast-ttl.c \
test/test-udp-open.c \
test/test-udp-options.c \
@@ -219,6 +223,13 @@ test_run_tests_SOURCES += test/runner-unix.c \
test/runner-unix.h
endif
+if AIX
+test_run_tests_CFLAGS += -D_ALL_SOURCE -D_XOPEN_SOURCE=500
+endif
+
+if SUNOS
+test_run_tests_CFLAGS += -D__EXTENSIONS__ -D_XOPEN_SOURCE=500
+endif
if AIX
@@ -226,6 +237,11 @@ libuv_la_CFLAGS += -D_ALL_SOURCE -D_XOPEN_SOURCE=500
libuv_la_SOURCES += src/unix/aix.c
endif
+if ANDROID
+include_HEADERS += include/android-ifaddrs.h
+libuv_la_SOURCES += src/unix/android-ifaddrs.c
+endif
+
if DARWIN
include_HEADERS += include/uv-darwin.h
libuv_la_CFLAGS += -D_DARWIN_USE_64_BIT_INODE=1
@@ -269,6 +285,9 @@ endif
if HAVE_DTRACE
BUILT_SOURCES = include/uv-dtrace.h
CLEANFILES += include/uv-dtrace.h
+if FREEBSD
+libuv_la_LDFLAGS += -lelf
+endif
endif
if DTRACE_NEEDS_OBJECTS