summaryrefslogtreecommitdiff
path: root/deps/uv/Makefile.am
diff options
context:
space:
mode:
authorcjihrig <cjihrig@gmail.com>2019-06-27 10:31:58 -0400
committercjihrig <cjihrig@gmail.com>2019-06-29 11:00:36 -0400
commit8772da6ea890afbe9088b71edf98fd3023090b00 (patch)
tree7e48cff80571d63daaf398c4736e16957151fd94 /deps/uv/Makefile.am
parent334bac79eb4cb9fd74348e7e30fe1222ca3de221 (diff)
downloadandroid-node-v8-8772da6ea890afbe9088b71edf98fd3023090b00.tar.gz
android-node-v8-8772da6ea890afbe9088b71edf98fd3023090b00.tar.bz2
android-node-v8-8772da6ea890afbe9088b71edf98fd3023090b00.zip
deps: upgrade to libuv 1.30.0
Notable changes: - Support for the Haiku platform has been added. - The maximum UV_THREADPOOL_SIZE has been increased from 128 to 1024. - uv_fs_copyfile() now works properly when the source and destination files are the same. PR-URL: https://github.com/nodejs/node/pull/28449 Fixes: https://github.com/nodejs/node/issues/27746 Reviewed-By: Trivikram Kamat <trivikr.dev@gmail.com> Reviewed-By: Jiawen Geng <technicalcute@gmail.com> Reviewed-By: Rich Trott <rtrott@gmail.com> Reviewed-By: Ben Noordhuis <info@bnoordhuis.nl>
Diffstat (limited to 'deps/uv/Makefile.am')
-rw-r--r--deps/uv/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/deps/uv/Makefile.am b/deps/uv/Makefile.am
index 07224f32b4..d213d8f4fa 100644
--- a/deps/uv/Makefile.am
+++ b/deps/uv/Makefile.am
@@ -117,6 +117,7 @@ endif # WINNT
EXTRA_DIST = test/fixtures/empty_file \
test/fixtures/load_error.node \
+ test/fixtures/lorem_ipsum.txt \
include \
docs \
img \
@@ -272,6 +273,7 @@ test_run_tests_SOURCES = test/blackhole-server.c \
test/test-tcp-writealot.c \
test/test-tcp-write-fail.c \
test/test-tcp-try-write.c \
+ test/test-tcp-try-write-error.c \
test/test-tcp-write-queue-order.c \
test/test-thread-equal.c \
test/test-thread.c \
@@ -320,6 +322,10 @@ test_run_tests_CFLAGS += -D_ALL_SOURCE \
-D_LINUX_SOURCE_COMPAT
endif
+if HAIKU
+test_run_tests_CFLAGS += -D_BSD_SOURCE
+endif
+
if LINUX
test_run_tests_CFLAGS += -D_GNU_SOURCE
endif
@@ -409,6 +415,17 @@ libuv_la_SOURCES += src/unix/bsd-ifaddrs.c \
test_run_tests_LDFLAGS += -lutil
endif
+if HAIKU
+uvinclude_HEADERS += include/uv/posix.h
+libuv_la_CFLAGS += -D_BSD_SOURCE
+libuv_la_SOURCES += src/unix/bsd-ifaddrs.c \
+ src/unix/haiku.c \
+ src/unix/no-fsevents.c \
+ src/unix/no-proctitle.c \
+ src/unix/posix-hrtime.c \
+ src/unix/posix-poll.c
+endif
+
if HURD
uvinclude_HEADERS += include/uv/posix.h
libuv_la_SOURCES += src/unix/no-fsevents.c \