summaryrefslogtreecommitdiff
path: root/deps/uv/Makefile.am
diff options
context:
space:
mode:
authorcjihrig <cjihrig@gmail.com>2016-10-24 22:13:07 -0400
committercjihrig <cjihrig@gmail.com>2016-10-26 09:42:41 -0400
commit63243bcb330408d511b3945c53719425d8b7abb8 (patch)
treef24252040adcc8c1a1dda22965fec39ac8df72de /deps/uv/Makefile.am
parent2d472a36c1d5e565fe375185f273402f84bed528 (diff)
downloadandroid-node-v8-63243bcb330408d511b3945c53719425d8b7abb8.tar.gz
android-node-v8-63243bcb330408d511b3945c53719425d8b7abb8.tar.bz2
android-node-v8-63243bcb330408d511b3945c53719425d8b7abb8.zip
deps: upgrade libuv to 1.10.0
Fixes: https://github.com/nodejs/node/issues/4351 Fixes: https://github.com/nodejs/node/issues/6763 Refs: https://github.com/nodejs/node/pull/8280 PR-URL: https://github.com/nodejs/node/pull/9267 Reviewed-By: Santiago Gimeno <santiago.gimeno@gmail.com> Reviewed-By: Ben Noordhuis <info@bnoordhuis.nl> Reviewed-By: James M Snell <jasnell@gmail.com>
Diffstat (limited to 'deps/uv/Makefile.am')
-rw-r--r--deps/uv/Makefile.am58
1 files changed, 57 insertions, 1 deletions
diff --git a/deps/uv/Makefile.am b/deps/uv/Makefile.am
index 05ccd58ac9..c232b6dbdc 100644
--- a/deps/uv/Makefile.am
+++ b/deps/uv/Makefile.am
@@ -36,7 +36,7 @@ libuv_la_SOURCES = src/fs-poll.c \
if SUNOS
# Can't be turned into a CC_CHECK_CFLAGS in configure.ac, it makes compilers
# on other platforms complain that the argument is unused during compilation.
-libuv_la_CFLAGS += -pthread
+libuv_la_CFLAGS += -pthreads
endif
if WINNT
@@ -48,6 +48,7 @@ AM_CPPFLAGS += -I$(top_srcdir)/src/win \
libuv_la_SOURCES += src/win/async.c \
src/win/atomicops-inl.h \
src/win/core.c \
+ src/win/detect-wakeup.c \
src/win/dl.c \
src/win/error.c \
src/win/fs-event.c \
@@ -128,7 +129,18 @@ EXTRA_DIST = test/fixtures/empty_file \
TESTS = test/run-tests
check_PROGRAMS = test/run-tests
+if OS390
test_run_tests_CFLAGS =
+else
+test_run_tests_CFLAGS = -Wno-long-long
+endif
+
+if SUNOS
+# Can't be turned into a CC_CHECK_CFLAGS in configure.ac, it makes compilers
+# on other platforms complain that the argument is unused during compilation.
+test_run_tests_CFLAGS += -pthreads
+endif
+
test_run_tests_LDFLAGS =
test_run_tests_SOURCES = test/blackhole-server.c \
test/dns-server.c \
@@ -215,6 +227,7 @@ test_run_tests_SOURCES = test/blackhole-server.c \
test/test-socket-buffer-size.c \
test/test-spawn.c \
test/test-stdio-over-pipes.c \
+ test/test-tcp-alloc-cb-fail.c \
test/test-tcp-bind-error.c \
test/test-tcp-bind6-error.c \
test/test-tcp-close-accept.c \
@@ -246,6 +259,7 @@ test_run_tests_SOURCES = test/blackhole-server.c \
test/test-timer.c \
test/test-tmpdir.c \
test/test-tty.c \
+ test/test-udp-alloc-cb-fail.c \
test/test-udp-bind.c \
test/test-udp-create-socket-early.c \
test/test-udp-dgram-too-big.c \
@@ -277,10 +291,29 @@ if AIX
test_run_tests_CFLAGS += -D_ALL_SOURCE -D_XOPEN_SOURCE=500 -D_LINUX_SOURCE_COMPAT
endif
+if LINUX
+test_run_tests_CFLAGS += -D_GNU_SOURCE
+endif
+
if SUNOS
test_run_tests_CFLAGS += -D__EXTENSIONS__ -D_XOPEN_SOURCE=500
endif
+if OS390
+test_run_tests_CFLAGS += -D_UNIX03_THREADS \
+ -D_UNIX03_SOURCE \
+ -D_OPEN_SYS_IF_EXT=1 \
+ -D_OPEN_SYS_SOCK_IPV6 \
+ -D_OPEN_MSGQ_EXT \
+ -D_XOPEN_SOURCE_EXTENDED \
+ -D_ALL_SOURCE \
+ -D_LARGE_TIME_API \
+ -D_OPEN_SYS_FILE_EXT \
+ -DPATH_MAX=255 \
+ -qCHARS=signed \
+ -qXPLINK \
+ -qFLOAT=IEEE
+endif
if AIX
libuv_la_CFLAGS += -D_ALL_SOURCE -D_XOPEN_SOURCE=500 -D_LINUX_SOURCE_COMPAT -D_THREAD_SAFE
@@ -312,6 +345,7 @@ endif
if DRAGONFLY
include_HEADERS += include/uv-bsd.h
+libuv_la_SOURCES += src/unix/freebsd.c src/unix/kqueue.c
test_run_tests_LDFLAGS += -lutil
endif
@@ -350,6 +384,28 @@ libuv_la_CFLAGS += -D__EXTENSIONS__ -D_XOPEN_SOURCE=500
libuv_la_SOURCES += src/unix/sunos.c
endif
+if OS390
+include_HEADERS += include/pthread-fixes.h include/pthread-barrier.h
+libuv_la_CFLAGS += -D_UNIX03_THREADS \
+ -D_UNIX03_SOURCE \
+ -D_OPEN_SYS_IF_EXT=1 \
+ -D_OPEN_MSGQ_EXT \
+ -D_XOPEN_SOURCE_EXTENDED \
+ -D_ALL_SOURCE \
+ -D_LARGE_TIME_API \
+ -D_OPEN_SYS_SOCK_IPV6 \
+ -D_OPEN_SYS_FILE_EXT \
+ -DUV_PLATFORM_SEM_T=int \
+ -DPATH_MAX=255 \
+ -qCHARS=signed \
+ -qXPLINK \
+ -qFLOAT=IEEE
+libuv_la_LDFLAGS += -qXPLINK
+libuv_la_SOURCES += src/unix/pthread-fixes.c \
+ src/unix/pthread-barrier.c
+libuv_la_SOURCES += src/unix/os390.c
+endif
+
if HAVE_PKG_CONFIG
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = @PACKAGE_NAME@.pc