summaryrefslogtreecommitdiff
path: root/deps/uv/CMakeLists.txt
diff options
context:
space:
mode:
authorcjihrig <cjihrig@gmail.com>2018-12-16 14:18:16 -0500
committercjihrig <cjihrig@gmail.com>2018-12-19 09:02:22 -0500
commit728b155870b69a83b806d8bee67aeb0fd0a9b2dd (patch)
treea15ca72c0ac6a6edd66f0845aa7779e0bbbea1f3 /deps/uv/CMakeLists.txt
parente1ab457490925ddbf9f234973c4338bd0690acb5 (diff)
downloadandroid-node-v8-728b155870b69a83b806d8bee67aeb0fd0a9b2dd.tar.gz
android-node-v8-728b155870b69a83b806d8bee67aeb0fd0a9b2dd.tar.bz2
android-node-v8-728b155870b69a83b806d8bee67aeb0fd0a9b2dd.zip
deps: upgrade to libuv 1.24.1
PR-URL: https://github.com/nodejs/node/pull/25078 Fixes: https://github.com/nodejs/node/issues/24521 Reviewed-By: James M Snell <jasnell@gmail.com> Reviewed-By: Daniel Bevenius <daniel.bevenius@gmail.com>
Diffstat (limited to 'deps/uv/CMakeLists.txt')
-rw-r--r--deps/uv/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/deps/uv/CMakeLists.txt b/deps/uv/CMakeLists.txt
index 8cd862715a..9f1c0587a9 100644
--- a/deps/uv/CMakeLists.txt
+++ b/deps/uv/CMakeLists.txt
@@ -15,6 +15,7 @@ set(uv_sources
src/fs-poll.c
src/idna.c
src/inet.c
+ src/strscpy.c
src/threadpool.c
src/timer.c
src/uv-common.c
@@ -116,6 +117,7 @@ set(uv_test_sources
test/test-socket-buffer-size.c
test/test-spawn.c
test/test-stdio-over-pipes.c
+ test/test-strscpy.c
test/test-tcp-alloc-cb-fail.c
test/test-tcp-bind-error.c
test/test-tcp-bind6-error.c
@@ -208,7 +210,11 @@ if(WIN32)
list(APPEND uv_test_sources src/win/snprintf.c test/runner-win.c)
else()
list(APPEND uv_defines _FILE_OFFSET_BITS=64 _LARGEFILE_SOURCE)
- list(APPEND uv_libraries pthread)
+ if(NOT CMAKE_SYSTEM_NAME STREQUAL "Android")
+ # Android has pthread as part of its c library, not as a separate
+ # libpthread.so.
+ list(APPEND uv_libraries pthread)
+ endif()
list(APPEND uv_sources
src/unix/async.c
src/unix/core.c