summaryrefslogtreecommitdiff
path: root/deps/nghttp2/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJames M Snell <jasnell@gmail.com>2018-04-13 07:51:35 -0700
committerMyles Borins <mylesborins@google.com>2018-06-12 20:46:55 -0400
commit01bc5713f9ec1653bb4f5c81f9cf07f594048f0c (patch)
tree36fd2ddb36e2c9f086015c9bc96ed7e2d3743ddb /deps/nghttp2/lib/CMakeLists.txt
parent8bf213dbdc7ee9c852252527f020d48e3bc97e15 (diff)
downloadandroid-node-v8-01bc5713f9ec1653bb4f5c81f9cf07f594048f0c.tar.gz
android-node-v8-01bc5713f9ec1653bb4f5c81f9cf07f594048f0c.tar.bz2
android-node-v8-01bc5713f9ec1653bb4f5c81f9cf07f594048f0c.zip
deps: update to nghttp2 1.32.0
This fixes CVE-2018-1000168. PR-URL: https://github.com/nodejs-private/node-private/pull/117 Reviewed-By: Matteo Collina <matteo.collina@gmail.com> Reviewed-By: Daniel Bevenius <daniel.bevenius@gmail.com> Reviewed-By: Colin Ihrig <cjihrig@gmail.com> Reviewed-By: Evan Lucas <evanlucas@me.com>
Diffstat (limited to 'deps/nghttp2/lib/CMakeLists.txt')
-rw-r--r--deps/nghttp2/lib/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/deps/nghttp2/lib/CMakeLists.txt b/deps/nghttp2/lib/CMakeLists.txt
index 0846d06789..17e422b22d 100644
--- a/deps/nghttp2/lib/CMakeLists.txt
+++ b/deps/nghttp2/lib/CMakeLists.txt
@@ -49,7 +49,7 @@ target_include_directories(nghttp2 INTERFACE
"${CMAKE_CURRENT_SOURCE_DIR}/includes"
)
-if(HAVE_CUNIT)
+if(HAVE_CUNIT OR ENABLE_STATIC_LIB)
# Static library (for unittests because of symbol visibility)
add_library(nghttp2_static STATIC ${NGHTTP2_SOURCES})
set_target_properties(nghttp2_static PROPERTIES
@@ -58,6 +58,10 @@ if(HAVE_CUNIT)
ARCHIVE_OUTPUT_NAME nghttp2
)
target_compile_definitions(nghttp2_static PUBLIC "-DNGHTTP2_STATICLIB")
+ if(ENABLE_STATIC_LIB)
+ install(TARGETS nghttp2_static
+ DESTINATION "${CMAKE_INSTALL_LIBDIR}")
+ endif()
endif()
install(TARGETS nghttp2