summaryrefslogtreecommitdiff
path: root/packages/exchange-backoffice-ui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/exchange-backoffice-ui/Makefile')
-rw-r--r--packages/exchange-backoffice-ui/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/exchange-backoffice-ui/Makefile b/packages/exchange-backoffice-ui/Makefile
new file mode 100644
index 000000000..34eb822a2
--- /dev/null
+++ b/packages/exchange-backoffice-ui/Makefile
@@ -0,0 +1,18 @@
+# This Makefile has been placed in the public domain
+
+# Settings from "./configure"
+include .config.mk
+
+all:
+ @echo run \'make install\' to install
+
+spa_dir=$(prefix)/share/taler/exchange-backoffice-ui
+
+install:
+ pnpm install --frozen-lockfile --filter @gnu-taler/exchange-backoffice-ui...
+ pnpm run check
+ pnpm run build
+ install -d $(spa_dir)
+ rm -rf ./dist/components
+ install ./dist/* $(spa_dir)
+