summaryrefslogtreecommitdiff
path: root/packages/auditor-backoffice-ui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/auditor-backoffice-ui/Makefile')
-rw-r--r--packages/auditor-backoffice-ui/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/auditor-backoffice-ui/Makefile b/packages/auditor-backoffice-ui/Makefile
new file mode 100644
index 000000000..57b3e0cb5
--- /dev/null
+++ b/packages/auditor-backoffice-ui/Makefile
@@ -0,0 +1,35 @@
+# This Makefile has been placed in the public domain
+
+ifeq ($(TOPLEVEL), yes)
+ $(info top-level build)
+ -include ../../.config.mk
+ override DESTDIR := $(TOP_DESTDIR)
+else
+ $(info package-level build)
+ -include ../../.config.mk
+ -include .config.mk
+endif
+
+$(info prefix is $(prefix))
+
+.PHONY: all
+all:
+ @echo run \'make install\' to install
+
+spa_dir=$(DESTDIR)$(prefix)/share/taler/auditor-backoffice
+
+.PHONY: deps
+deps:
+ pnpm install --frozen-lockfile --filter @gnu-taler/auditor-backoffice...
+ pnpm run build
+
+.PHONY: install-nodeps
+install-nodeps:
+ (cd dist/prod && find . -type f -exec install -D "{}" "$(spa_dir)/{}" \;)
+
+
+.PHONY: install
+install:
+ $(MAKE) deps
+ $(MAKE) install-nodeps
+