summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7c9c084..1b9d517 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@
AC_PREREQ([2.69])
AC_INIT([taler-mdb], [0.8.2], [taler@gnu.org])
-AC_CONFIG_SRCDIR([src/main.c])
+AC_CONFIG_SRCDIR([src/taler-mdb.c])
AC_CONFIG_HEADERS([config.h])
# Checks for programs.
@@ -13,9 +13,15 @@ AC_PROG_CC
# Checks for libraries.
AC_CHECK_LIB([nfc], [nfc_open])
+# Checks for libraries.
+AC_CHECK_LIB([usb], [libusb_init])
+
# Checks for header files.
AC_CHECK_HEADERS([stdlib.h string.h unistd.h sys/un.h netinet/in.h netinet/ip.h])
+# Checks for header files.
+AC_CHECK_HEADERS([libusb-1.0/libusb.h])
+
# Checks for typedefs, structures, and compiler characteristics.
AC_CHECK_HEADER_STDBOOL
AC_TYPE_SIZE_T