summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2019-10-30 17:37:42 +0100
committerBOSS_Marco <bossm8@students.bfh.ch>2019-10-31 16:08:02 +0100
commit8c04a7af83a83eefce4046be358d857632cd8376 (patch)
tree77fa1f8bae341a3783047cf51df88cc26bb1ed38 /src/Makefile.am
parent895f886cbe84c1b3cf1aa7583f30913e9ee052c4 (diff)
downloadtaler-mdb-8c04a7af83a83eefce4046be358d857632cd8376.tar.gz
taler-mdb-8c04a7af83a83eefce4046be358d857632cd8376.tar.bz2
taler-mdb-8c04a7af83a83eefce4046be358d857632cd8376.zip
revisit build system, except for libnfc should work
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..3105b63
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,28 @@
+# This Makefile.am is in the public domain
+bin_PROGRAMS = taler-nfc
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+taler_nfc_SOURCES = \
+ nfc.c nfc.h \
+ wallet.c wallet.h \
+ product.c product.h \
+ communication.c communication.h \
+ main.c
+taler_nfc_LDADD = \
+ -ljansson \
+ -lnfc \
+ -lpthread \
+ $(XLIB)
+
+
+if HAVE_LIBCURL
+taler_nfc_LDADD += -lcurl
+else
+if HAVE_LIBGNURL
+taler_nfc_LDADD += -lgnurl
+endif
+endif