summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2019-10-30 17:43:20 +0100
committerBOSS_Marco <bossm8@students.bfh.ch>2019-10-31 16:08:06 +0100
commitd7af56fad383298ea87eb4ba869e872e250912bc (patch)
tree9c16d0e7a18a860769bb43e9e3781c95380f98d4 /configure.ac
parentf4180723aad23835f98ede5e12d88b4604cb5ade (diff)
downloadtaler-mdb-d7af56fad383298ea87eb4ba869e872e250912bc.tar.gz
taler-mdb-d7af56fad383298ea87eb4ba869e872e250912bc.tar.bz2
taler-mdb-d7af56fad383298ea87eb4ba869e872e250912bc.zip
fix nfc and other build issues
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 0 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index c10bfe4..0551c7c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -105,33 +105,6 @@ AS_IF([test "$gnurl" = 1],
AM_CONDITIONAL(HAVE_LIBCURL, false)
AC_DEFINE([HAVE_LIBCURL],[0],[Lacking libcurl])])])
-# Check for GNUnet's libgnunetcurl.
-libgnunetcurl=0
-AC_MSG_CHECKING([for libgnunetcurl])
-AC_ARG_WITH(gnunet,
- [AS_HELP_STRING([--with-gnunet=PFX], [base of GNUnet installation])],
- [AC_MSG_RESULT([given as $with_gnunet])],
- [AC_MSG_RESULT(not given)
- with_gnunet=yes])
-AS_CASE([$with_gnunet],
- [yes], [],
- [no], [AC_MSG_ERROR([--with-gnunet is required])],
- [LDFLAGS="-L$with_gnunet/lib $LDFLAGS"
- CPPFLAGS="-I$with_gnunet/include $CPPFLAGS"])
-AC_CHECK_HEADERS([gnunet/platform.h gnunet/gnunet_curl_lib.h],
- [AC_CHECK_LIB([gnunetcurl], [GNUNET_CURL_get_select_info], libgnunetcurl=1)],
- [], [#ifdef HAVE_GNUNET_PLATFORM_H
- #include <gnunet/platform.h>
- #endif])
-AS_IF([test $libgnunetcurl != 1],
- [AC_MSG_ERROR([[
-***
-*** You need libgnunetcurl to build this program.
-*** Make sure you have libcurl or libgnurl installed while
-*** building GNUnet.
-*** ]])])
-
-
# Restore after gnurl/curl checks messed up these values
CFLAGS=$CFLAGS_SAVE
LDFLAGS=$LDFLAGS_SAVE