summaryrefslogtreecommitdiff
path: root/src/testing/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testing/Makefile.am')
-rw-r--r--src/testing/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/src/testing/Makefile.am b/src/testing/Makefile.am
index 13ff35f..0fd3d03 100644
--- a/src/testing/Makefile.am
+++ b/src/testing/Makefile.am
@@ -15,10 +15,7 @@ libsynctesting_la_LDFLAGS = \
libsynctesting_la_SOURCES = \
testing_api_cmd_backup_download.c \
testing_api_cmd_backup_upload.c \
- testing_api_helpers.c \
- testing_api_trait_account_pub.c \
- testing_api_trait_account_priv.c \
- testing_api_trait_hash.c
+ testing_api_traits.c
libsynctesting_la_LIBADD = \
$(top_builddir)/src/lib/libsync.la \
-ltalermerchant \
@@ -32,6 +29,8 @@ libsynctesting_la_LIBADD = \
-ltalertesting \
$(XLIB)
+AM_TESTS_ENVIRONMENT=export SYNC_PREFIX=$${SYNC_PREFIX:-@libdir@};export PATH=$${SYNC_PREFIX:-@prefix@}/bin:$$PATH;
+
check_PROGRAMS = \
test_sync_api
@@ -40,8 +39,7 @@ TESTS = \
EXTRA_DIST = \
test_sync_api.conf \
- test_sync_api_home/.config/taler/exchange/account-2.json \
- test_sync_api_home/.local/share/taler/exchange/offline-keys/master.priv
+ test_sync_api_home/.local/share/taler/exchange-offline/master.priv
test_sync_api_SOURCES = \
test_sync_api.c