summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c8d2fb1..7cb6627 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,6 +109,12 @@ AX_LIB_POSTGRESQL([9.3])
AS_IF([test "x$found_postgresql" = "xyes"],[postgres=true])
AM_CONDITIONAL(HAVE_POSTGRESQL, test x$postgres = xtrue)
+SYNC_LIB_LDFLAGS="-export-dynamic -no-undefined"
+SYNC_PLUGIN_LDFLAGS="-export-dynamic -avoid-version -module -no-undefined"
+
+AC_SUBST(SYNC_LIB_LDFLAGS)
+AC_SUBST(SYNC_PLUGIN_LDFLAGS)
+
# Check for Taler's libtalerpq
libtalerpq=0
AC_MSG_CHECKING([for libtalerpq])