summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2019-11-14 18:51:46 +0100
committerChristian Grothoff <christian@grothoff.org>2019-11-14 18:51:46 +0100
commit0ccb604a22f4134c682a5399aedfc239de2f608b (patch)
tree5ed833a27ca78320b7b94b56891049713a9c9326 /src/util/Makefile.am
parentc8047726772c2f4a18a6b0ebc7ce879bf260860a (diff)
downloadsync-0ccb604a22f4134c682a5399aedfc239de2f608b.tar.gz
sync-0ccb604a22f4134c682a5399aedfc239de2f608b.tar.bz2
sync-0ccb604a22f4134c682a5399aedfc239de2f608b.zip
wip
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
new file mode 100644
index 0000000..bc1291c
--- /dev/null
+++ b/src/util/Makefile.am
@@ -0,0 +1,28 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include $(LIBGCRYPT_CFLAGS)
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+
+pkgcfgdir = $(prefix)/share/sync/config.d/
+
+pkgcfg_DATA = \
+ paths.conf
+
+bin_SCRIPTS = \
+ sync-config
+
+lib_LTLIBRARIES = \
+ libsyncutil.la
+
+libsyncutil_la_SOURCES = \
+ os_installation.c
+libsyncutil_la_LIBADD = \
+ -lgnunetutil \
+ $(XLIB)
+libsyncutil_la_LDFLAGS = \
+ -version-info 0:0:0 \
+ -export-dynamic -no-undefined