summaryrefslogtreecommitdiff
path: root/src/syncdb/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2019-11-25 16:00:37 +0100
committerChristian Grothoff <christian@grothoff.org>2019-11-25 16:00:37 +0100
commite982d9fe320cb8fe3726af061fec178ba03e5252 (patch)
tree388fb658a0eca5c1a2a3e66564aac12cce2cefb6 /src/syncdb/Makefile.am
parentcbd5fbd796b18916ea032021661397369fbcbd22 (diff)
downloadsync-e982d9fe320cb8fe3726af061fec178ba03e5252.tar.gz
sync-e982d9fe320cb8fe3726af061fec178ba03e5252.tar.bz2
sync-e982d9fe320cb8fe3726af061fec178ba03e5252.zip
add sync-dbinit tool
Diffstat (limited to 'src/syncdb/Makefile.am')
-rw-r--r--src/syncdb/Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/src/syncdb/Makefile.am b/src/syncdb/Makefile.am
index e181df9..d5c92fa 100644
--- a/src/syncdb/Makefile.am
+++ b/src/syncdb/Makefile.am
@@ -15,12 +15,24 @@ if USE_COVERAGE
XLIB = -lgcov
endif
+bin_PROGRAMS = \
+ sync-dbinit
+
+sync_dbinit_SOURCES = \
+ sync-dbinit.c
+sync_dbinit_LDADD = \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/util/libsyncutil.la \
+ -lsyncdb \
+ -lgnunetutil \
+ -ltalerutil \
+ -ltalerpq
+
+
lib_LTLIBRARIES = \
libsyncdb.la
-
libsyncdb_la_SOURCES = \
sync_db_plugin.c
-
libsyncdb_la_LIBADD = \
$(top_builddir)/src/util/libsyncutil.la \
-lgnunetpq \