summaryrefslogtreecommitdiff
path: root/src/syncdb/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2019-11-13 15:01:09 +0100
committerChristian Grothoff <christian@grothoff.org>2019-11-13 15:01:09 +0100
commitc8047726772c2f4a18a6b0ebc7ce879bf260860a (patch)
treea6bab2e9a42c72a720c893b9c2505077067e6bfc /src/syncdb/Makefile.am
downloadsync-c8047726772c2f4a18a6b0ebc7ce879bf260860a.tar.gz
sync-c8047726772c2f4a18a6b0ebc7ce879bf260860a.tar.bz2
sync-c8047726772c2f4a18a6b0ebc7ce879bf260860a.zip
skeleton
Diffstat (limited to 'src/syncdb/Makefile.am')
-rw-r--r--src/syncdb/Makefile.am62
1 files changed, 62 insertions, 0 deletions
diff --git a/src/syncdb/Makefile.am b/src/syncdb/Makefile.am
new file mode 100644
index 0000000..56db964
--- /dev/null
+++ b/src/syncdb/Makefile.am
@@ -0,0 +1,62 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include
+
+plugindir = $(libdir)/taler
+
+if HAVE_POSTGRESQL
+if HAVE_GNUNETPQ
+plugin_LTLIBRARIES = \
+ libsync_plugin_db_postgres.la
+endif
+endif
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+lib_LTLIBRARIES = \
+ libsyncdb.la
+
+libsyncdb_la_SOURCES = \
+ sync_db_plugin.c
+
+libsyncdb_la_LIBADD = \
+ -lgnunetpq \
+ -lpq \
+ -lgnunetutil
+libsyncdb_la_LDFLAGS = \
+ $(POSTGRESQL_LDFLAGS) \
+ -version-info 2:0:0 \
+ -no-undefined
+
+libsync_plugin_db_postgres_la_SOURCES = \
+ plugin_sync_postgres.c
+libsync_plugin_db_postgres_la_LIBADD = \
+ $(LTLIBINTL)
+libsync_plugin_db_postgres_la_LDFLAGS = \
+ $(TALER_PLUGIN_LDFLAGS) \
+ -lgnunetpq \
+ -lpq \
+ -ltalerpq \
+ -lgnunetutil $(XLIB)
+
+check_PROGRAMS = \
+ $(TESTS)
+
+test_sync_db_postgres_SOURCES = \
+ test_sync_db.c
+test_sync_db_postgres_LDFLAGS = \
+ $(top_builddir)/src/util/libsyncutil.la \
+ libsyncdb.la \
+ -lgnunetutil \
+ -lgnunetpq \
+ -ltalerutil \
+ -ltalerpq \
+ -luuid
+
+TESTS = \
+ test_sync_db-postgres
+
+EXTRA_DIST = \
+ test_sync_db_postgres.conf