summaryrefslogtreecommitdiff
path: root/doc/doxygen/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2024-02-18 15:32:49 +0100
committerChristian Grothoff <christian@grothoff.org>2024-02-18 15:32:49 +0100
commit7ae3b90e4a32c7e1fb8149ba47463140733ae532 (patch)
treed078b850721bb77213df7cd519aded4f8caaf967 /doc/doxygen/Makefile.am
parente9fb9e5936714bd97b1027ca5bd78c9eee1eeb87 (diff)
downloadsync-7ae3b90e4a32c7e1fb8149ba47463140733ae532.tar.gz
sync-7ae3b90e4a32c7e1fb8149ba47463140733ae532.tar.bz2
sync-7ae3b90e4a32c7e1fb8149ba47463140733ae532.zip
add doxygen to build system
Diffstat (limited to 'doc/doxygen/Makefile.am')
-rw-r--r--doc/doxygen/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/doc/doxygen/Makefile.am b/doc/doxygen/Makefile.am
new file mode 100644
index 0000000..1e171de
--- /dev/null
+++ b/doc/doxygen/Makefile.am
@@ -0,0 +1,18 @@
+# This Makefile.am is in the public domain
+all:
+ @echo -e \
+"Generate documentation:\n" \
+"\tmake full - full documentation with dependency graphs (slow)\n" \
+"\tmake fast - fast mode without dependency graphs"
+
+full: sync.doxy
+ doxygen $<
+
+fast: sync.doxy
+ sed 's/\(HAVE_DOT.*=\).*/\1 NO/' $< | doxygen -
+
+clean:
+ rm -rf html
+
+EXTRA_DIST = \
+ sync.doxy