summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-09-25 18:04:04 +0000
committerng0 <ng0@n0.is>2019-09-25 18:04:04 +0000
commit107efba7d60ff0a3d56b48661d70d5842395a836 (patch)
treea5b2d9d17bb5794fd5668be5f6734154e5d0acdd /setup.py
parenteeff7dbd327d5e136ac9998b9f2e077a9e4a78a7 (diff)
parent498b14392f7f828af1a239d680da27b859f85033 (diff)
downloadsurvey-107efba7d60ff0a3d56b48661d70d5842395a836.tar.gz
survey-107efba7d60ff0a3d56b48661d70d5842395a836.tar.bz2
survey-107efba7d60ff0a3d56b48661d70d5842395a836.zip
Merge branch 'master' of git.taler.net:survey
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py58
1 files changed, 30 insertions, 28 deletions
diff --git a/setup.py b/setup.py
index 3daed2c..612ea9d 100755
--- a/setup.py
+++ b/setup.py
@@ -1,30 +1,32 @@
from setuptools import setup, find_packages
-setup(name='talersurvey',
- version='0.0',
- description='Example survey site for GNU Taler',
- url='git://taler.net/survey',
- author='Marcello Stanisci',
- author_email='stanisci.m@gmail.com',
- license='GPL',
- packages=find_packages(),
- install_requires=["Flask>=0.10", "taler-util"],
- test_suite="nose.collector",
- tests_require=["mock", "nose"],
- package_data={
- '':[
- "survey/templates/*.html",
- "survey/static/favicon.ico",
- "survey/static/*.svg",
- "survey/static/*.css",
- "survey/static/*.js",
- "survey/static/*.js.tar.gz",
- "survey/static/web-common/*.png",
- "survey/static/web-common/*.css",
- "survey/static/web-common/*.js",
- "survey/static/web-common/*.js.tar.gz",
- "survey/static/web-common/*.html",
- ]
- },
- scripts=['taler-merchant-survey'],
- zip_safe=False)
+setup(
+ name='talersurvey',
+ version='0.6.0pre1',
+ description='Example survey site for GNU Taler',
+ url='git://taler.net/survey',
+ author='Marcello Stanisci',
+ author_email='stanisci.m@gmail.com',
+ license='GPL',
+ packages=find_packages(),
+ install_requires=["Flask>=0.10", "jsmin", "taler-util"],
+ test_suite="nose.collector",
+ tests_require=["mock", "nose", "requests", "uwsgi", "qrcode", "lxml"],
+ package_data={
+ '': [
+ "survey/templates/*.html",
+ "survey/static/favicon.ico",
+ "survey/static/*.svg",
+ "survey/static/*.css",
+ "survey/static/*.js",
+ "survey/static/*.js.tar.gz",
+ "survey/static/web-common/*.png",
+ "survey/static/web-common/*.css",
+ "survey/static/web-common/*.js",
+ "survey/static/web-common/*.js.tar.gz",
+ "survey/static/web-common/*.html",
+ ]
+ },
+ scripts=['./bin/taler-merchant-survey'],
+ zip_safe=False
+)