summaryrefslogtreecommitdiff
path: root/rs/fflate-wasm/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Dold <florian@dold.me>2021-08-20 13:31:03 +0200
committerFlorian Dold <florian@dold.me>2021-08-20 13:31:03 +0200
commit859a8734c87d5e5081d7b0aa02cb538a7c801eac (patch)
treed2e9163479eb56ec382c842d62ce39fe30d450a4 /rs/fflate-wasm/Cargo.toml
downloadnode-vendor-859a8734c87d5e5081d7b0aa02cb538a7c801eac.tar.gz
node-vendor-859a8734c87d5e5081d7b0aa02cb538a7c801eac.tar.bz2
node-vendor-859a8734c87d5e5081d7b0aa02cb538a7c801eac.zip
Squashed 'fflate/' content from commit b786929
git-subtree-dir: fflate git-subtree-split: b786929a368521e9cfcdcf7490a8e77485d5a253
Diffstat (limited to 'rs/fflate-wasm/Cargo.toml')
-rw-r--r--rs/fflate-wasm/Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/rs/fflate-wasm/Cargo.toml b/rs/fflate-wasm/Cargo.toml
new file mode 100644
index 0000000..77751e0
--- /dev/null
+++ b/rs/fflate-wasm/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "fflate-wasm"
+version = "0.0.1"
+authors = ["Arjun Barrett <arjunbarrett@gmail.com>"]
+edition = "2018"
+
+[dependencies]
+fflate = { path = "../fflate", features = ["std"] }
+wasm-bindgen = "0.2"
+
+[profile.release]
+opt-level = "s"
+lto = true
+
+[package.metadata.wasm-pack.profile.release]
+wasm-opt = ["-Oz", "--enable-mutable-globals"]
+
+[lib]
+crate-type = ["cdylib", "rlib"] \ No newline at end of file