aboutsummaryrefslogtreecommitdiff
path: root/src/testing/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testing/Makefile.am')
-rw-r--r--src/testing/Makefile.am29
1 files changed, 25 insertions, 4 deletions
diff --git a/src/testing/Makefile.am b/src/testing/Makefile.am
index e64f0b18..2e3532bd 100644
--- a/src/testing/Makefile.am
+++ b/src/testing/Makefile.am
@@ -82,7 +82,8 @@ libtalermerchanttesting_la_LIBADD = \
if HAVE_TALERFAKEBANK
check_PROGRAMS = \
- test_merchant_api
+ test_merchant_api \
+ test_kyc_api
if HAVE_TWISTER
check_PROGRAMS += test_merchant_api_twisted
@@ -134,9 +135,30 @@ test_merchant_api_LDADD = \
-ljansson \
$(XLIB)
+test_kyc_api_SOURCES = \
+ test_kyc_api.c
+test_kyc_api_LDADD = \
+ libtalermerchanttesting.la \
+ $(top_srcdir)/src/backenddb/libtalermerchantdb.la \
+ $(top_srcdir)/src/lib/libtalermerchant.la \
+ $(LIBGCRYPT_LIBS) \
+ -ltalertesting \
+ -ltalerfakebank \
+ -ltalerbank \
+ -ltalerexchange \
+ -ltalerjson \
+ -ltalerutil \
+ -lgnunetjson \
+ -lgnunetcurl \
+ -lgnunetutil \
+ -ljansson \
+ $(XLIB)
+
EXTRA_DIST = \
initialize_taler_system.sh \
- test_template.conf \
+ test_key_rotation.sh \
+ test_key_rotation.conf \
+ test_kyc_api.conf \
test_merchant_api.conf \
test_merchant_api_twisted.conf \
test_merchant_api_proxy_merchant.conf \
@@ -145,8 +167,7 @@ EXTRA_DIST = \
test_merchant_api_home/.local/share/taler/exchange/offline-keys/master.priv \
test_merchant_api_home/.config/taler/exchange/account-2.json \
test_merchant.priv \
- test_key_rotation.sh \
- test_key_rotation.conf \
+ test_template.conf \
$(check_SCRIPTS)