summaryrefslogtreecommitdiff
path: root/src/testing/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testing/Makefile.am')
-rw-r--r--src/testing/Makefile.am55
1 files changed, 28 insertions, 27 deletions
diff --git a/src/testing/Makefile.am b/src/testing/Makefile.am
index 159b922e..67bbbced 100644
--- a/src/testing/Makefile.am
+++ b/src/testing/Makefile.am
@@ -8,74 +8,79 @@ endif
check_SCRIPTS = \
- test-merchant-walletharness.sh \
test_merchant_instance_auth.sh \
+ test_merchant_instance_creation.sh \
test_merchant_instance_response.sh \
test_merchant_instance_purge.sh \
- test_merchant_reserve_creation.sh \
test_merchant_product_creation.sh \
test_merchant_order_creation.sh \
- test_merchant_transfer_tracking.sh
-
+ test_merchant_transfer_tracking.sh \
+ test_merchant_kyc.sh \
+ test_merchant_order_autocleanup.sh \
+ test_merchant_wirewatch.sh \
+ test-merchant-walletharness.sh
lib_LTLIBRARIES = \
libtalermerchanttesting.la
libtalermerchanttesting_la_LDFLAGS = \
- -version-info 2:0:0 \
+ -version-info 4:0:1 \
-no-undefined
libtalermerchanttesting_la_SOURCES = \
testing_api_cmd_config.c \
testing_api_cmd_abort_order.c \
testing_api_cmd_claim_order.c \
+ testing_api_cmd_depositcheck.c \
testing_api_cmd_get_instance.c \
testing_api_cmd_get_instances.c \
testing_api_cmd_get_orders.c \
+ testing_api_cmd_get_otp_device.c \
+ testing_api_cmd_get_otp_devices.c \
testing_api_cmd_get_product.c \
testing_api_cmd_get_products.c \
- testing_api_cmd_get_reserve.c \
- testing_api_cmd_get_reserves.c \
- testing_api_cmd_get_tips.c \
testing_api_cmd_get_transfers.c \
testing_api_cmd_get_templates.c \
testing_api_cmd_get_template.c \
testing_api_cmd_get_webhooks.c \
testing_api_cmd_get_webhook.c \
+ testing_api_cmd_delete_account.c \
testing_api_cmd_delete_instance.c \
testing_api_cmd_delete_order.c \
+ testing_api_cmd_delete_otp_device.c \
testing_api_cmd_delete_product.c \
testing_api_cmd_delete_template.c \
testing_api_cmd_delete_webhook.c \
- testing_api_cmd_delete_reserve.c \
testing_api_cmd_delete_transfer.c \
testing_api_cmd_forget_order.c \
testing_api_cmd_kyc_get.c \
testing_api_cmd_lock_product.c \
testing_api_cmd_instance_auth.c \
testing_api_cmd_merchant_get_order.c \
- testing_api_cmd_merchant_get_tip.c \
+ testing_api_cmd_patch_instance.c \
+ testing_api_cmd_patch_otp_device.c \
+ testing_api_cmd_patch_product.c \
+ testing_api_cmd_patch_template.c \
+ testing_api_cmd_patch_webhook.c \
testing_api_cmd_pay_order.c \
+ testing_api_cmd_post_account.c \
testing_api_cmd_post_instances.c \
testing_api_cmd_post_orders_paid.c \
testing_api_cmd_post_orders.c \
+ testing_api_cmd_post_otp_devices.c \
testing_api_cmd_post_products.c \
- testing_api_cmd_post_reserves.c \
testing_api_cmd_post_transfers.c \
testing_api_cmd_post_templates.c \
+ testing_api_cmd_post_tokenfamilies.c \
testing_api_cmd_post_using_templates.c \
testing_api_cmd_post_webhooks.c \
- testing_api_cmd_patch_instance.c \
- testing_api_cmd_patch_product.c \
- testing_api_cmd_patch_template.c \
- testing_api_cmd_patch_webhook.c \
testing_api_cmd_refund_order.c \
- \
- testing_api_cmd_tip_authorize.c \
- testing_api_cmd_tip_pickup.c \
+ testing_api_cmd_tme.c \
testing_api_cmd_wallet_get_order.c \
- testing_api_cmd_wallet_get_tip.c \
testing_api_cmd_wallet_post_orders_refund.c \
+ testing_api_cmd_webhook.c \
+ testing_api_cmd_testserver.c \
+ testing_api_cmd_checkserver.c \
testing_api_helpers.c \
testing_api_traits.c
@@ -84,11 +89,13 @@ libtalermerchanttesting_la_LIBADD = \
-ltalerbank \
-ltalerexchange \
-ltalerjson \
+ -ltalermhd \
-ltalerutil \
-lgnunetcurl \
-lgnunetjson \
-lgnunetutil \
-ljansson \
+ -lmicrohttpd \
-ltalertesting \
$(XLIB)
@@ -125,7 +132,6 @@ test_merchant_api_twisted_cs_LDADD = \
-ltalerexchange \
-ltalerjson \
-ltalerutil \
- -lgnunettesting \
-lgnunetjson \
-lgnunetcurl \
-lgnunetutil \
@@ -147,7 +153,6 @@ test_merchant_api_twisted_rsa_LDADD = \
-ltalerexchange \
-ltalerjson \
-ltalerutil \
- -lgnunettesting \
-lgnunetjson \
-lgnunetcurl \
-lgnunetutil \
@@ -168,7 +173,6 @@ test_merchant_api_cs_LDADD = \
-ltalerexchange \
-ltalerjson \
-ltalerutil \
- -lgnunettesting \
-lgnunetjson \
-lgnunetcurl \
-lgnunetutil \
@@ -188,7 +192,6 @@ test_merchant_api_rsa_LDADD = \
-ltalerexchange \
-ltalerjson \
-ltalerutil \
- -lgnunettesting \
-lgnunetjson \
-lgnunetcurl \
-lgnunetutil \
@@ -215,10 +218,10 @@ test_kyc_api_LDADD = \
$(XLIB)
EXTRA_DIST = \
- initialize_taler_system.sh \
- test_key_rotation.sh \
+ setup.sh \
test_key_rotation.conf \
test_kyc_api.conf \
+ test_merchant_api.conf \
test_merchant_api-cs.conf \
test_merchant_api-rsa.conf \
test_merchant_api_twisted-cs.conf \
@@ -226,8 +229,6 @@ EXTRA_DIST = \
test_merchant_api_proxy_merchant.conf \
test_merchant_api_proxy_exchange.conf \
test_merchant_api_home/.local/share/taler/exchange-offline/master.priv \
- test_merchant_api_home/.local/share/taler/exchange/offline-keys/master.priv \
- test_merchant_api_home/.config/taler/exchange/account-2.json \
test_merchant.priv \
test_template.conf \
$(check_SCRIPTS)