summaryrefslogtreecommitdiff
path: root/src/samples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/samples/Makefile.am')
-rw-r--r--src/samples/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/samples/Makefile.am b/src/samples/Makefile.am
new file mode 100644
index 00000000..f51998dd
--- /dev/null
+++ b/src/samples/Makefile.am
@@ -0,0 +1,21 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include
+
+bin_PROGRAMS = \
+ merchant-create-payments
+
+merchant_create_payments_SOURCES = \
+ create_payments.c
+
+merchant_create_payments_LDADD = \
+ $(top_srcdir)/src/backenddb/libtalermerchantdb.la \
+ -ltalermerchant \
+ $(LIBGCRYPT_LIBS) \
+ -ltalerfakebank \
+ -ltalerexchange \
+ -ltalerjson \
+ -ltalerutil \
+ -lgnunetjson \
+ -lgnunetcurl \
+ -lgnunetutil \
+ -ljansson