summaryrefslogtreecommitdiff
path: root/src/merchant-tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/merchant-tools/Makefile.am')
-rw-r--r--src/merchant-tools/Makefile.am21
1 files changed, 14 insertions, 7 deletions
diff --git a/src/merchant-tools/Makefile.am b/src/merchant-tools/Makefile.am
index 987a0897..21ddb89a 100644
--- a/src/merchant-tools/Makefile.am
+++ b/src/merchant-tools/Makefile.am
@@ -7,9 +7,16 @@ if USE_COVERAGE
endif
bin_PROGRAMS = \
- taler-merchant-benchmark \
taler-merchant-dbinit \
- taler-merchant-setup-reserve
+ taler-merchant-passwd \
+ taler-merchant-benchmark
+
+EXTRA_DIST = \
+ benchmark-common.conf \
+ benchmark-cs.conf \
+ benchmark-rsa.conf \
+ coins-cs.conf \
+ coins-rsa.conf
taler_merchant_benchmark_SOURCES = \
taler-merchant-benchmark.c
@@ -40,12 +47,12 @@ taler_merchant_dbinit_LDADD = \
-lgnunetutil \
$(XLIB)
-taler_merchant_setup_reserve_SOURCES = \
- taler-merchant-setup-reserve.c
-taler_merchant_setup_reserve_LDADD = \
+taler_merchant_passwd_SOURCES = \
+ taler-merchant-passwd.c
+taler_merchant_passwd_LDADD = \
$(LIBGCRYPT_LIBS) \
- $(top_builddir)/src/lib/libtalermerchant.la \
+ $(top_builddir)/src/backenddb/libtalermerchantdb.la \
-ltalerutil \
- -lgnunetcurl \
+ -ltalerpq \
-lgnunetutil \
$(XLIB)