summaryrefslogtreecommitdiff
path: root/src/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/Makefile.am')
-rw-r--r--src/lib/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
new file mode 100644
index 00000000..8696db40
--- /dev/null
+++ b/src/lib/Makefile.am
@@ -0,0 +1,47 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+lib_LTLIBRARIES = \
+ libtalermerchant.la
+
+libtalermerchant_la_LDFLAGS = \
+ -version-info 0:0:0 \
+ -no-undefined
+
+libtalermerchant_la_SOURCES = \
+ merchant_api_context.c merchant_api_context.h \
+ merchant_api_json.c merchant_api_json.h \
+ merchant_api_pay.c
+
+libtalermerchant_la_LIBADD = \
+ -lgnunetutil \
+ -ljansson \
+ $(XLIB)
+
+if HAVE_LIBCURL
+libtalermerchant_la_LIBADD += -lcurl
+else
+if HAVE_LIBGNURL
+libtalermerchant_la_LIBADD += -lgnurl
+endif
+endif
+
+check_PROGRAMS = \
+ test_merchant_api
+
+TESTS = \
+ $(check_PROGRAMS)
+
+test_merchant_api_SOURCES = \
+ test_merchant_api.c
+test_merchant_api_LDADD = \
+ libtalermerchant.la \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetutil \
+ -ljansson