summaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index 4344aac7..1eb6fa6d 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -9,7 +9,16 @@ dist_tmplpkgdata_DATA = \
request_payment.en.must \
show_order_details.en.must
-# Note: if you update pure-min.css, you must also update the MUST templates above!
+.mcpp.must:
+ cpp -E -C -P -undef -nostdinc < $< > $@ 2> /dev/null
+
+# Note: only works when building from Git, if you
+# run maintainer clean against the TGZ, you will
+# not be able to recover...
+MAINTAINERCLEANFILES = \
+ $(dist_tmplpkgdata_DATA)
+
+# Note: if you update pure-min.css, you must also update the MCPP/MUST templates above!
dist_staticpkgdata_DATA = \
pure-min.css